Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162030 - partition utility allows user to forget /boot partition
Summary: partition utility allows user to forget /boot partition
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 10:29 UTC by Ra P.
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-08 18:21:27 UTC


Attachments (Terms of Use)

Description Ra P. 2005-06-29 10:29:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
My first installation of fc4 failed (it did boot, but the first-run wizard did not load, so it was severely messed up), because I forgot to create a /boot partition during install. The partition utility should have told me I needed at least three partitions / /boot /swap and not let me continue without them.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Use FC4 installer
2. In the partition utility, do not create a /boot partition
3. Continue with install
  

Actual Results:  The system boots, but the first-run wizard does not run and all is messed up.

Expected Results:  At stage 2, the installer should have warned me a /boot partition was necessary.

Additional info:

Comment 1 Jeremy Katz 2005-07-08 18:21:27 UTC
/boot is only required in a subset of cases like using LVM for /.  This is
caught.  If you're doing flat partitions, having no /boot is perfectly
acceptable for the majority of hardware currently supported by Fedora Core.


Note You need to log in before you can comment on or make changes to this bug.