Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162026 - selinux updated policies 1.17.30-3.13 released 27th June break crossover office 4.2 and mod_perl.so
Summary: selinux updated policies 1.17.30-3.13 released 27th June break crossover offi...
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy-targeted
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Daniel Walsh
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 09:36 UTC by David
Modified: 2008-05-01 15:38 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-04 00:49:24 UTC


Attachments (Terms of Use)

Description David 2005-06-29 09:36:43 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
I applied the SElinux updates as released on 27th June 2005 using the taskbar up2date tool. Crossover office 4.2 now no-longer works. When I try to run an installed windows application I get the following in /var/log/messages

Jun 29 18:17:34 dhcppc0 kernel: audit(1120034854.440:0): avc:  denied
{ execmod } for  pid=4353 comm=wine-preloader
path=/opt/cxoffice/lib/wine/ntdll.dll.so dev=dm-0 ino=82386
scontext=user_u:system_r:unconfined_t tcontext=system_u:object_r:lib_t
tclass=file

And when trying to start cxoffice setup I get:

wine failed to initialise: /opt/cxoffice/lib/wine/ntdll.dll.so cannot
restore segment prot after reloc: Permission denied.

If I turn SElinux off with setenforce 0 then crossover office (and installed windows applications) work just fine.

There is also a boot up error that reports an error in line 10 of /etc/httd/conf.d/perl.conf - this line appears to be trying to load mod_perl.so Again I suspect SElinux is the cause of this error.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.Click MS Word Icon
2.Wait
3.Check /var/logs/messages
  

Actual Results:  Word failed to load. 
/var/logs/messages contains:

Jun 29 18:17:34 dhcppc0 kernel: audit(1120034854.440:0): avc:  denied
{ execmod } for  pid=4353 comm=wine-preloader
path=/opt/cxoffice/lib/wine/ntdll.dll.so dev=dm-0 ino=82386
scontext=user_u:system_r:unconfined_t tcontext=system_u:object_r:lib_t
tclass=file

Expected Results:  MS Word (withing cxoffice) should have loaded.

Additional info:

Comment 1 Daniel Walsh 2005-07-03 15:21:23 UTC
Fixed in selinux-policy-targeted-1.17.30-3.16

Comment 2 David 2005-07-04 00:49:24 UTC
Confirmed - I applied the updates. They fix the problem. Thanks.


Note You need to log in before you can comment on or make changes to this bug.