Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162018 - galculator segfaults on startup after numerous libglade warnings
Summary: galculator segfaults on startup after numerous libglade warnings
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: galculator
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phillip Compton
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-06-29 05:57 UTC by Steven Blake
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-25 18:54:48 UTC


Attachments (Terms of Use)
Patch to apply to the sources to fix this bug (deleted)
2005-07-02 20:12 UTC, Kevin Kofler
no flags Details | Diff
Specfile patch to apply the source patch (deleted)
2005-07-02 20:21 UTC, Kevin Kofler
no flags Details | Diff

Description Steven Blake 2005-06-29 05:57:15 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
galculator-1.2.4-3 from Fedora Extras 4 on a FC4 x86_64 install segfaults every time after spewing several libglade warnings (shown below).  The FC4 install is running on an AMD Athlon 64 3000+ box with all packages up to date (from updates-released and extras only).

gtk2-2.6.7-4
libglade-0.17-16


Version-Release number of selected component (if applicable):
galculator-1.2.4-3 (x86_64)

How reproducible:
Always

Steps to Reproduce:
1.Enter galculator at shell prompt
2.
3.
  

Actual Results:  The following is output to stderr:
----------------------------------


(galculator:9394): libglade-WARNING **: could not find signal handler 'on_dec_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_hex_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_formula_entry_changed'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_quit_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_preferences1_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_display_control_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_logical_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_standard_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_copy_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_basic_mode_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_oct_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_ordinary_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_cut_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_scientific_mode_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_textview_selection_received'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_paste_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_bin_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_deg_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_about_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_textview_button_press_event'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_functions_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_rpn_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_button_press_event'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_show_menubar1_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_grad_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_formula_entry_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_main_window_check_resize'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_rad_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_form_activate'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_constant_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_mr_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_function_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_operation_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_number_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_ms_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_gfunc_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_togglebutton_released'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_user_function_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_mplus_button_clicked'.

(galculator:9394): libglade-WARNING **: could not find signal handler 'on_tbutton_fmod_clicked'.

(galculator:9394): libglade-CRITICAL **: glade_xml_get_widget: assertion `self != NULL' failed
Segmentation fault

Expected Results:  galculator window should have opened.

Additional info:

I've put a copy of the output of strace galculator at:
http://www.petri-meat.com/slblake/pubs/strace-galculator.out

Comment 1 Kevin Kofler 2005-06-29 09:33:48 UTC
I have that too.

The fix (which I've already tested on other Glade-based software with the same 
problem) should be to link the executable with -Wl,--export-dynamic so libglade 
can find the callbacks.

Comment 2 Kevin Kofler 2005-07-02 20:12:41 UTC
Created attachment 116294 [details]
Patch to apply to the sources to fix this bug

Here's a patch to fix this problem. This has to be applied to the sources.

Comment 3 Kevin Kofler 2005-07-02 20:21:34 UTC
Created attachment 116295 [details]
Specfile patch to apply the source patch

This (currently untested) specfile patch applies the source patch (previous
attachment) and also fixes the broken SourceForge download link for Source0.

Comment 4 Brian Mury 2005-07-07 23:29:58 UTC
I believe this is fixed in 1.2.5.

Comment 5 Kevin Kofler 2005-07-14 03:20:31 UTC
Can someone please fix this? It should only be a matter of either applying my 
patches or upgrading to the latest upstream. And you don't risk breaking 
anything since the app currently doesn't work at all.

Comment 6 Michael Schwendt 2005-07-25 18:54:48 UTC
Update to 1.2.5 shall fix this. May take a few days until packages will appear
in the repository.



Note You need to log in before you can comment on or make changes to this bug.