Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 162008 - libwnck bindings don't work
Summary: libwnck bindings don't work
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-python2-desktop
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-29 01:49 UTC by Juha Sahakangas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: gnome-python2-desktop-2.16.0-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-30 03:04:21 UTC


Attachments (Terms of Use)

Description Juha Sahakangas 2005-06-29 01:49:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
wnck bindings break on import.


Version-Release number of selected component (if applicable):
gnome-python2-extras-2.10.0-2.1

How reproducible:
Always

Steps to Reproduce:
1. python
2. import wnck


Actual Results:  ImportError: /usr/lib/python2.4/site-packages/gtk-2.0/wnck.so: undefined symbol: wnck_create_window_menu


Expected Results:  wnck module should get imported.

Additional info:

This bug has been fixed in upstream stable release, updating fedora core rpm's to gnome-python-extras 2.10.2 would fix the problem.

Comment 1 Matthew Barnes 2006-10-30 03:04:21 UTC
This seems to be working now in Fedora Core 6, so I'm closing this bug.  Please
feel free to reopen it if you still encounter the problem.

The wnck module is now provided by gnome-python2-libwnck, a subpackage of
gnome-python2-desktop.  Fedora Core 6 has gnome-python2-desktop-2.16.0-1.fc6.


Note You need to log in before you can comment on or make changes to this bug.