Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1620 - kernel panic on mkfs, also on boot
Summary: kernel panic on mkfs, also on boot
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: installer
Version: 5.2
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-03-19 01:11 UTC by hydrastis
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-30 17:36:49 UTC


Attachments (Terms of Use)

Description hydrastis 1999-03-19 01:11:44 UTC
I tried to install rh 5.2 on 3 machines recently.  they are
all dual-400mhz pentium ii's on asus motherboards, with 512
megs of ram, (first quantum, then) seagate scsi drives,
adaptec 2940, and 3com 905b.

I tried installing on each individual machine, and 2 of the
three had this problem:
	a. If you request that the swap partitions are checked for
bad blocks, it begins and then hangs at about 85% done on
the first swap partition.
	b. if you don't check bad blocks on swap parts, a message
comes up while mke2fs is running, and the system is halted.
the message is "kernel panic: free list corrupted".

	c.  on the machine that i know works, install rh5.2 to all
three hard drives in turn.  put the other 2 hard drives in
their machines.  the first time booting these hard drives in
the 2 questionable boxes i had no problems...
but any time after that i get "kernel panic: free list
corrupted" ***while it is fsck'ing one of the partitions***.

any suggestions would be greatly appreciated.


------- Additional Comments From   03/22/99 15:11 -------
As I mentioned, I already tried swapping the drives out.  Today, i attempted installing with new scsi controller cards.
Install is still hanging(at least on mkswap, the one i've tested so far today).  when mkswap hangs, alt-f4 gives me the following message(repeated many times):
<4> Problem: block on freelist at 17fcbc90 isn't free.

Comment 1 Doug Ledford 1999-04-07 20:36:59 UTC
This problem should be fixed by the 5.1.12 or later version of the
aic7xxx driver.  Unfortunately, there isn't a Red Hat Linux 5.2 boot
disk or kernel that uses that driver version.  The latest one in a Red
Hat kernel is 5.1.11 in the 2.0.36-3 kernel rpm.  When the 5.1.15
aic7xxx driver has stabalized, then we can consider a boot disk based
upon that driver version.


Note You need to log in before you can comment on or make changes to this bug.