Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161996 - several RPMs require /usr/bin/rebuild-security-providers but dont list it in dependencies
Summary: several RPMs require /usr/bin/rebuild-security-providers but dont list it in ...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: jpackage-utils
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Thomas Fitzsimmons
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 23:23 UTC by Dan Hollis
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-04 01:12:33 UTC


Attachments (Terms of Use)

Description Dan Hollis 2005-06-28 23:23:22 UTC
Description of problem:
several RPMs require /usr/bin/rebuild-security-providers in their %postun, but
said RPMs do not list this as a dependency.

thus it is possible to eg rpm -e jpackage-utils and
/usr/bin/rebuild-security-providers will disappear. then it becomes difficult to
rpm -e these other packages because they error out trying to call a nonexistent
/usr/bin/rebuild-security-providers in their %postun.

it is possible to rpm -e these broken rpms with --noscripts, but meh. it
shouldnt be needed.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.rpm -e jpackage-utils
2.rpm -e (various other java packages)
3.join communist party
  
Actual results:
profit! :-(

Expected results:
It should uninstall them without barfing (or rather, trying to remove
jpackage-utils should whine that it would break dependencies in other packages
due to their dependency on /usr/bin/rebuild-security-providers)

Additional info:

Comment 1 Matthieu Pupat 2005-07-03 11:53:14 UTC
confirmed with:

java-1.4.2-gcj-compat
gnu-crypto
jessie


Same problem with update-desktop-database for:

openoffice.org-core
redhat-menus


Comment 2 Thomas Fitzsimmons 2005-10-01 21:40:04 UTC
Yes, I plan to create a separate java-gcj-compat-scripts package that includes
/usr/bin/rebuild-security-providers.  Then packages that use
rebuild-security-providers can require this -scripts package.

Please file separate bug reports against openoffice.org-core and redhat-menus.


Comment 3 Thomas Fitzsimmons 2006-02-04 01:12:33 UTC
java-1.4.2-gcj-compat, gnu-crypto and jessie now contain these Requires lines:

Requires(post): jpackage-utils >= 0:1.6.3-1jpp_1rh
Requires(postun): jpackage-utils >= 0:1.6.3-1jpp_1rh

rebuild-security-providers was introduced in jpackage-utils-1.6.3-1jpp_1rh. 
Closing.



Note You need to log in before you can comment on or make changes to this bug.