Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161993 - 2 glibc rpms installed after upgrade from FC3 to FC4
Summary: 2 glibc rpms installed after upgrade from FC3 to FC4
Keywords:
Status: CLOSED DUPLICATE of bug 160585
Alias: None
Product: Fedora
Classification: Fedora
Component: redhat-lsb
Version: 4
Hardware: i386
OS: Linux
medium
low
Target Milestone: ---
Assignee: Leon Ho
QA Contact:
URL:
Whiteboard:
: 160155 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 22:32 UTC by Hubert Verstraete
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-15 01:23:25 UTC


Attachments (Terms of Use)

Description Hubert Verstraete 2005-06-28 22:32:12 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.6) Gecko/20050328 Fedora/1.7.6-1.2.5

Description of problem:
After the upgrade from FC3 to FC4, I have two glibc installed:
$ rpm -q glibc
glibc-2.3.5-0.fc3.1
glibc-2.3.5-10

The first one comes from FC3. The second from FC4.
The whole content of the FC3 rpm is also contained in the FC4 rpm.

Should I and could I remove the FC3 rpm without any risk?

Version-Release number of selected component (if applicable):
glibc-2.3.5-0.fc3.1 glibc-2.3.5-10

How reproducible:
Didn't try

Steps to Reproduce:
1. fresh install Fedora Core 3
2. apply all available updates (with yum or other)
3. upgrade to Fedore Core 4

Actual Results:  Everything runs well, but it looks like I have two glibc rpms installed at once:
$ rpm -q glibc
glibc-2.3.5-0.fc3.1
glibc-2.3.5-10

Expected Results:  I would have expected:
$ rpm -q glibc
glibc-2.3.5-10

Additional info:

Comment 1 Jakub Jelinek 2005-06-29 13:34:52 UTC
That sounds like glibc's %post failed, can you find some error messages in
update.log that would show what's going on?


Comment 2 Hubert Verstraete 2005-06-29 13:42:37 UTC
You're alright, here is the error message from upgrade.log:

Upgrading glibc-2.3.5-10.i686.
error: %trigger(redhat-lsb-1.3-4.i386) scriptlet failed, exit status 255

Comment 3 Jakub Jelinek 2005-06-29 13:44:24 UTC
That suggests a bug in redhat-lsb...

Comment 4 Leon Ho 2005-07-05 01:49:12 UTC
*** Bug 160155 has been marked as a duplicate of this bug. ***

Comment 5 Chris Ricker 2005-07-05 16:36:23 UTC
This is basically a duplicate of Bug 160585 which has jbj's explanation of What
Went Wrong

Comment 6 Leon Ho 2005-07-15 01:23:25 UTC

*** This bug has been marked as a duplicate of 160585 ***


Note You need to log in before you can comment on or make changes to this bug.