Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161974 - creates borken fence_manual configuration
Summary: creates borken fence_manual configuration
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Cluster Suite
Classification: Retired
Component: redhat-config-cluster
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jim Parsons
QA Contact: Cluster QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 20:20 UTC by Katriel Traum
Modified: 2009-04-16 20:09 UTC (History)
1 user (show)

Fixed In Version: RHBA-2005-753
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-07 16:48:37 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2005:753 normal SHIPPED_LIVE system-config-cluster bug update 2005-10-07 04:00:00 UTC

Description Katriel Traum 2005-06-28 20:20:52 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Creating a fence_manual agent and attaching it to a node creates a cluter.conf without "nodename" or "ipaddr" config option which causes fence_manual to fail on node fencing.

syslog reports:
Jun 28 23:04:11 node1 fenced[1839]: fence "node2" failed
Jun 28 23:04:16 node1 fenced[1839]: fencing node "node2"
Jun 28 23:04:16 node1 fenced[1839]: agent "fence_manual" reports: failed: fence_manual no node name

cluster.conf section looks like:
<method name="1">
     <device name="manfence"/>
</method>

should be:
<method name="1">
     <device name="manfence" nodename="node name">
</method>


Version-Release number of selected component (if applicable):
system-config-cluster-1.0.12-1.0

How reproducible:
Always

Steps to Reproduce:
1.Create new config with system-config-cluster
2.Create fence_manual fencing device, attach to node, save cnew config
3.New config is invalid
  

Additional info:

Comment 1 Stanko Kupcevic 2005-08-04 20:22:09 UTC
Fixed in Errata Candidate

Comment 2 Corey Marthaler 2005-09-07 17:10:59 UTC
fix verified in 1.0.15

Comment 3 Red Hat Bugzilla 2005-10-07 16:48:37 UTC
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-753.html



Note You need to log in before you can comment on or make changes to this bug.