Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161968 - cpuspeed fails to start on Pentium-M Dothan Centrino Processor
Summary: cpuspeed fails to start on Pentium-M Dothan Centrino Processor
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: cpuspeed
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 19:43 UTC by Eugene Roux
Modified: 2015-01-04 22:20 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-05 19:26:03 UTC


Attachments (Terms of Use)

Description Eugene Roux 2005-06-28 19:43:28 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.20

Description of problem:
cpuspeed fails when I attempt to start it without specifying a DRIVER variable in /etc/cpuspeed.conf.

Since the speedstep_centrino driver is compiled into the kernel, one would expect it to start without problem, but I get a "Error: Could not open file for writing: /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor" when I start cpuspeed.

If I change the DRIVER="p4-clockmod" in /etc/cpuspeed.conf, cpuspeed starts, albeit with a "p4-clockmod: Warning: Pentium M detected. The speedstep_centrino module offers voltage scaling in addition of frequency scaling. You should use that instead of p4-clockmod, if possible." warning.

/proc/cpuinfo gives:
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 6
model           : 13
model name      : Intel(R) Pentium(R) M processor 1.60GHz
stepping        : 6
cpu MHz         : 1595.109
cache size      : 2048 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr mce cx8 mtrr pge mca cmov pat clflush dts acpi mmx fxsr sse sse2 ss tm pbe est tm2
bogomips        : 3162.11

Which is supposedly supported by 2.6.9 onwards...

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
See description

Actual Results:  See description

Expected Results:  CPU scaling should work

Additional info:

Comment 1 Dave Jones 2005-07-05 19:26:03 UTC
The driver doesn't support Dothan core CPUs. Unfortunatly it likely never will
unless we get relevant information from Intel to determine which set of voltages
are safe to use.  We have no way of knowing which of the 4 sets of VID pins are
in use, and guessing could potentially damage systems, so we're stuck with the
current situation.



Note You need to log in before you can comment on or make changes to this bug.