Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161966 - make fails with fs/nfs/nfs4xdr.c: In function `encode_lookup':
Summary: make fails with fs/nfs/nfs4xdr.c: In function `encode_lookup':
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: i686
OS: Linux
medium
high
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 19:40 UTC by Rainer Enders
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-06 19:29:40 UTC


Attachments (Terms of Use)

Description Rainer Enders 2005-06-28 19:40:35 UTC
Description of problem: 
  
make of the kernel source tree fails with error. 
 
Version-Release number of selected component (if applicable): 
 
 
How reproducible: 
run make in  
/usr/src/redhat/BUILD/kernel-2.6.11/linux-2.6.11 
 
 
Steps to Reproduce: 
1.run 'rpm -i kernel-2.6.11-1.1369_FC4.src.rpm' 
2.Change directory to /usr/src/redhat/SPECS/, and issue the following command: 
  
 rpmbuild -bp --target=i686 kernel-2.6.spec 
  
 
3.cd to /usr/src/redhat/BUILD/kernel-2.6.11/linux-2.6.11 
and run make 
   
Actual results: 
  CC [M]  fs/nfs/unlink.o 
  CC [M]  fs/nfs/write.o  
  CC [M]  fs/nfs/nfs3proc.o 
  CC [M]  fs/nfs/nfs3xdr.o 
  CC [M]  fs/nfs/nfs4proc.o 
  CC [M]  fs/nfs/nfs4xdr.o 
fs/nfs/nfs4xdr.c: In function âencode_lookupâ: 
fs/nfs/nfs4xdr.c:782: internal compiler error: Segmentation fault 
Please submit a full bug report, 
with preprocessed source if appropriate. 
See <URL:http://bugzilla.redhat.com/bugzilla> for instructions. 
The bug is not reproducible, so it is likely a hardware or OS problem. 
make[2]: *** [fs/nfs/nfs4xdr.o] Error 1 
make[1]: *** [fs/nfs] Error 2 
make: *** [fs] Error 2 
 
Expected results: 
 
 
Additional info:

Comment 1 Jakub Jelinek 2005-07-06 19:29:40 UTC
The:
"The bug is not reproducible, so it is likely a hardware or OS problem."
part in the message means that the GCC driver couldn't reproduce the problem.
The most likely cause in such cases is flakey hardware, so you should
certainly start with checking your hardware.



Note You need to log in before you can comment on or make changes to this bug.