Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161964 - rhdb-jonas init script does not honor the sysconfig PGPORT setting
Summary: rhdb-jonas init script does not honor the sysconfig PGPORT setting
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Application Server Public Beta
Classification: Retired
Component: jonas
Version: 2.0-beta
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Fernando Nasser
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 19:36 UTC by Fernando Nasser
Modified: 2007-04-18 17:28 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 17:45:35 UTC


Attachments (Terms of Use)

Description Fernando Nasser 2005-06-28 19:36:04 UTC
Description of problem:

Setting PGPORT in /etc/sysconfig/rhdb-jonas has no effect


Version-Release number of selected component (if applicable):

RHAPS V2 Beta


How reproducible:

Always


Steps to Reproduce:
1. Set PGPORT to 5434 in /etc/sysconfig/rhdb-jonas
2. service rhdb-jonas start
3. try connecting to the database on 5434, then try 5433 
  
Actual results:

database is listening on 5433, not 5434

Expected results:

database listening on 5434

Additional info:

The idea was not to have a copy of the postgresql init script.  This was done
only because the community version of the init script was not configurable.  The
new versions of postgresql come with our sysconfig setting scheme in
/etc/sysconfig/pgsql subdirectory though) so we can now just create a symbolic
link to the init script installed by the postgresql package.

Comment 1 Fernando Nasser 2005-06-29 17:45:35 UTC
Fixed on rpms > 4.4.2-1jpp_13rh

/etc/rc.d/init.d/rhdb-jonas is now a link to /etc/rc.d/init.d/postgresql

and the configuration is now at

/etc/sysconfig/pgsql/rhdb-jonas


Note You need to log in before you can comment on or make changes to this bug.