Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161921 - perl.req does not catch "use base 'something';"
Summary: perl.req does not catch "use base 'something';"
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 14:28 UTC by Simon Perreault
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-13 10:16:13 UTC


Attachments (Terms of Use)

Description Simon Perreault 2005-06-28 14:28:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.4; Linux) KHTML/3.4.1 (like Gecko)

Description of problem:
perl.req, which parses perl files to figure out their requirements, does not 
get requirements of this form (which are fairly common): 
 
use base 'SomeModule'; 
 
This is a common way to inherit from SomeModule. 

Version-Release number of selected component (if applicable):
rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. Create this file: 
=== 
package Derived; 
use base 'Parent'; 
=== 
2. Run /usr/lib/rpm/perl.req on it. 

Actual Results:  perl(base) 

Expected Results:  perl(base) 
perl(Parent) 

Additional info:

Comment 1 James Olin Oden 2005-06-28 19:52:48 UTC
Paul,

I put something like this in the HEAD, long time ago (about six months ago).
I don't remember if I only added it to Chip Turners or also to the default one.

Cheers...james

Comment 2 Jeff Johnson 2005-07-13 10:16:13 UTC
Change was to eprldeps.pl, not perl.req.

I've changed the default macros to use perldeps.pl, not perl.{req,prov} (which will be
phased out entirely very soon now) in rpm-4_4 cvs. Should be in rpm-4.4.2-0.8 when built.


Note You need to log in before you can comment on or make changes to this bug.