Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161914 - tg3 driver does not detect network on GigE
Summary: tg3 driver does not detect network on GigE
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: John W. Linville
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 13:59 UTC by Christian Huettermann
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-16 14:22:58 UTC


Attachments (Terms of Use)

Description Christian Huettermann 2005-06-28 13:59:55 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050512 Red Hat/1.0.4-1.4.1 MSIE/6.0

Description of problem:
On a Dell X300 laptop the tg3 network driver does not seem to detect the network at all, when connected to a Cisco GigE switch port. When connected to a 100MBit switch it works. When downscaling the switch port on the Cisco side, it works as well.
Booting the laptop via PXE happily gives the PXE screen, so it seems to be an issue with the tg3 driver.
Trying to tune the tg3 card via ethtool (setting speed, duplex etc) did not bring any different results either.

Version-Release number of selected component (if applicable):
kernel-2.6.9-11.EL

How reproducible:
Always

Steps to Reproduce:
1. connect laptop to GigE switchport
2. ifup eth0 - no joy
3. connect laptop to 100M switchport or downscale switchport
4. ifup eth0 - works, happy dhcp.
  

Actual Results:  "Check cable" message 

Expected Results:  Happy dhcp'ing network device getting an IP Address

Additional info:

Comment 1 jgarcia 2005-06-28 14:48:11 UTC
jgarcia@redhat.com

Comment 2 John W. Linville 2005-06-28 20:19:41 UTC
Does it work w/ the Cisco switch if you use a statically assigned IP address? 

Comment 3 Christian Huettermann 2005-06-28 23:28:48 UTC
Yes

Comment 4 John W. Linville 2005-06-29 14:31:09 UTC
Is the Cisco switch configured for spanning tree protocol (STP) on that port?  
If so, it should be turned-off.  STP doesn't serve much purpose on a "leaf" 
port (i.e. a port connected to an end-station) anyway. 
 
STP progresses a newly activated port through a number of stages in which the 
link is physically active, but the switch is not allowing it to communicate to 
the rest of the network.  Since the physical link is active, the DHCP client 
proceeds to issue requests.  Since the switch is still not passing traffic on 
that port, the DHCP requests go unanswered.  Often the DHCP client will 
timeout and give-up before STP on the switch has transition the port to a 
forwarding state. 
 
All of the above can be avoided by disabling STP on the switch port (or by 
using a static IP address).  Does disabling STP (presuming that it is 
currently active) improve the situation for you? 

Comment 5 Christian Huettermann 2005-06-30 09:09:42 UTC
Thank you but we already checked that as first thing and STP was and is 
disabled on that port (default for our user ports). And we would get the 
same problems or at least the 30 seconds delay while the switchport is 
throttled to 100 Mbit but there it works flawlessly.
We also checked that the port has trunking explicitly disabled and not 
on auto sensing. We tried also a different port and cable.

Comment 6 John W. Linville 2005-06-30 12:27:22 UTC
I do have RHEL4 test kernels w/ a tg3 driver update available here: 
 
   http://people.redhat.com/linville/kernels/rhel4/ 
 
Let's start by trying those kernels to see if things clear-up?  Even if not, 
we'll need to start w/ that as a base.  Please post the results of your 
testing here...thanks! 

Comment 7 John W. Linville 2005-07-06 19:37:27 UTC
New kernels at the same location, w/ latest tg3 driver from upstream...FYI... 

Comment 8 John W. Linville 2005-09-16 14:22:58 UTC
Closing due to lack of response.  Please re-open when current testing 
information becomes available. 


Note You need to log in before you can comment on or make changes to this bug.