Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161907 - Could not link driver rlm_sql_mysql: file not found
Summary: Could not link driver rlm_sql_mysql: file not found
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: freeradius
Version: 3.0
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Thomas Woerner
QA Contact:
URL:
Whiteboard:
: 161909 193830 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 12:31 UTC by Marius Onica
Modified: 2007-11-30 22:07 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-01 14:38:45 UTC


Attachments (Terms of Use)

Description Marius Onica 2005-06-28 12:31:16 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050523 Red Hat/1.7.8-1.1.3.1

Description of problem:
After compiling the packet when trying to start freeradius I receive this:

 sql: safe-characters = "@abcdefghijklmnopqrstuvwxyzABCDEFGHIJKLMNOPQRSTUVWXYZ0123456789.-_: /"
rlm_sql (sql1): Could not link driver rlm_sql_mysql: file not found
rlm_sql (sql1): Make sure it (and all its dependent libraries!) are in the search path of your system's ld.
radiusd.conf[14]: sql1: Module instantiation failed.



Version-Release number of selected component (if applicable):
freeradius-1.0.1-1.1.RHEL3

How reproducible:
Always

Steps to Reproduce:
1.radiusd -X
2.
3.
  

Actual Results:  The program refuses to start.

Additional info:

Comment 1 Thomas Woerner 2005-06-28 12:51:22 UTC
Why are you recompiling the package?

Comment 2 Marius Onica 2005-06-28 13:15:28 UTC
Partly because I need the sqlcounter module also, partly because I'm not
subscribed to RH Network so I compile from source all the updates.
The above described problem appears also if the unmodified  source package is
compiled.


Comment 3 Thomas Woerner 2005-06-28 13:23:41 UTC
*** Bug 161909 has been marked as a duplicate of this bug. ***

Comment 4 Thomas Woerner 2005-06-28 13:26:42 UTC
Have you installed the freeradius-mysql package which contains rlm_sql_mysql.?


Comment 5 Marius Onica 2005-06-28 13:40:47 UTC
Yes, and all the necessary files are present.

Comment 6 Stijn Jonker 2005-07-02 17:31:26 UTC
I also encountered this issue, when i copy the file from
/usr/src/redhat/BUILD/freeradius-1.0.1/src/modules/rlm_sql/drivers/lib/rlm_sql_mysql.la
to /usr/lib freeradius starts and at first glance it seems to work.

Comment 7 Stijn Jonker 2005-07-02 17:32:31 UTC
Sorry forgot to add, I don't know what's causing it, but strace radiusd -f -X
told me he couldn't find the file and I found it in the build directory ;-)

So let's call it a workaround ...

Comment 8 Thomas Woerner 2005-07-19 13:03:46 UTC
You have to use the .so file, not the .la.

Please verify this problem with the original packages.

Comment 9 Andy Saunders 2005-07-27 15:57:16 UTC
I'm running Red Hat Enterprise Linux AS release 3 (Taroon Update 5) and the
following packages are installed

freeradius-1.0.1-1.1.RHEL3
freeradius-mysql-1.0.1-1.1.RHEL3

/sbin/service radius start

gives the following in /var/log/radius/radius.log

Wed Jul 27 16:53:12 2005 : Error: rlm_sql (sql): Could not link driver
rlm_sql_mysql: file not found
Wed Jul 27 16:53:12 2005 : Error: rlm_sql (sql): Make sure it (and all its
dependent libraries!) are in the search path of your system's ld.
Wed Jul 27 16:53:12 2005 : Error: radiusd.conf[14]: sql: Module instantiation
failed.

Running strace gives

open("/usr/lib/rlm_sql_mysql.la", O_RDONLY) = -1 ENOENT (No such file or directory)

The system has /usr/lib/rlm_sql_mysql.so (provided by freeradius-mysql) but not
/usr/lib/rlm_sql_mysql.la


Comment 10 David Herselman 2006-05-29 15:47:17 UTC
I'm experiencing the same problem with freeradius-1.0.1-2.RHEL3.2 and 
freeradius-mysql-1.0.1-2.RHEL3.2.

Any reason this bug hasn't been fixed (Been almost a year now)?

Comment 11 Thomas Woerner 2006-06-07 09:56:45 UTC
*** Bug 193830 has been marked as a duplicate of this bug. ***

Comment 12 Thomas Woerner 2006-06-07 11:03:53 UTC
Please have a look at
http://people.redhat.com/twoerner/BZ/3.0E/freeradius-1.0.1-2.RHEL3.3.src.rpm

BTW: There was no freeradius-mysql package in RHEL-3.

This package should resolve the problem.

----
Please remeber that this is a test package, which might be pushed out as an
update package later if the fixes are ok. For now, this package is unsupported.

Comment 13 Thomas Woerner 2006-06-07 13:21:15 UTC
Here is the correct link:
http://people.redhat.com/twoerner/BZ/161907/freeradius-1.0.1-2.RHEL3.3.src.rpm

Comment 14 David Herselman 2006-06-26 16:56:42 UTC
Many thanks, the compiled package works perfectly!

Comment 15 Thomas Woerner 2006-08-01 14:38:45 UTC
I am closing this, becaus there was no freeradius-mysql for RHEL-3.


Note You need to log in before you can comment on or make changes to this bug.