Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161905 - Gimp is missing Wacom Volito pressure sensitivity
Summary: Gimp is missing Wacom Volito pressure sensitivity
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gimp
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Nils Philippsen
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 12:15 UTC by Joakim Svensson
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 19:23:27 UTC


Attachments (Terms of Use)

Description Joakim Svensson 2005-06-28 12:15:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
My Wacom Volito(1), is working fine as a mouse, moving the cursor on the screen according to pen on the pad. But the pen doesn't show up in Gimp 2.2.7 > Preferences > Input Devices, therefore I can't use the pressure sensitivity. 

I'm not sure it's a bug, but it's a feature that I think should work "out-of-the-box".

Version-Release number of selected component (if applicable):
2.2.7

How reproducible:
Always

Steps to Reproduce:
1. Plug in Wacom Volito into USB
2. Start Fedora Core 4, with Gnome
3. Start The Gimp 2.2.7
4. Create document and move pen around

Actual Results:  It didn't detect any pressure changes, it's on 100% pressure all the time.

Expected Results:  Lines I draw should change according to the pressure amount given.

Additional info:

http://www.software-documentation.org/wacom-tablet.html �7.1

"Gimp Input Devices Dialog shows "No Input Devices" Gnome and
Gimp only work like a usual mouse, without pressure and tilt.

It seems that you have not compiled your gtk with XInput-support.
Please rebuild gtk and use ./configure --with-xinput=xfree for
building the Makefile. Then do a make && make install. Then rebuild
your gimp so that it uses this extendet gtk."

Comment 1 Joakim Svensson 2005-06-28 19:23:27 UTC
After some reading and some modification, the problem is no more.
I made the following changes in xorg.conf:

In [Section "ServerLayout"] I added
InputDevice    "cursor"    "SendCoreEvents"
InputDevice    "stylus"    "SendCoreEvents"

and in [Section "InputDevice"] I added

Section "InputDevice"
  Driver        "wacom"
  Identifier    "cursor"
  Option        "Device"        "/dev/input/event2"
  Option        "Type"          "cursor"
  Option        "USB"           "on"
EndSection

and

Section "InputDevice"
  Driver        "wacom"
  Identifier    "stylus"
  Option        "Device"        "/dev/input/event2"
  Option        "Type"          "stylus"
  Option        "USB"           "on"
EndSection

Well, guess it's no bug then, but I don't think my grandma would be up to the
task adding stuff in xorg.conf, so I think it should be added automatically if a
Wacom unit is detected.


Note You need to log in before you can comment on or make changes to this bug.