Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161901 - Add repoview listing of Fedora Core packages like Fedora Extras
Summary: Add repoview listing of Fedora Core packages like Fedora Extras
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora Infrastructure
Classification: Retired
Component: website
Version: unspecified
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Elliot Lee
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 10:45 UTC by Alex Lancaster
Modified: 2013-01-10 03:39 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-15 23:05:42 UTC


Attachments (Terms of Use)

Description Alex Lancaster 2005-06-28 10:45:47 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Galeon/1.3.21

Description of problem:
It would be useful if http://fedora.redhat.com/ (as well as http://fedoraproject.org/) could have a prominently-linked repoview-generated list of packages in Fedora Core like Fedora Extras (FE).  

Currently FE has repoview enabled:

http://fedoraproject.org/extras/4/i386/repodata/
http://download.fedora.redhat.com/pub/fedora/linux/extras/4/i386/repodata/

(although there is no link to either of these repoviews on http://fedora.redhat.com/projects/extras/)

For consistency the URL(s) would be:

http://fedoraproject.org/core/4/i386/repodata/
http://download.fedora.redhat.com/pub/fedora/linux/core/4/i386/repodata/

(or somesuch)

Currently there appears to be no way to get a good human-readable overview of the packages in FC4 on a website except for looking through the RPMS directory (or using a GUI yumex or synaptic).

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. View fedora.redhat.com
2.
3.
  

Additional info:

Comment 1 Alex Lancaster 2005-06-28 11:00:16 UTC
Would also be useful to add Updates to this list, if possible, so you could see
at a glance the list of most recently updated FC4 packages.

Comment 2 Alex Lancaster 2005-06-28 11:08:12 UTC
http://fedoraproject.org/wiki/FedoraExtrasSchedule lists 
"Repoview for fedora.redhat.com/packages/" as being "closed" on 21 Apr with the
a comment that "repoview will be very useful for Fedora Core as well as for
Fedora Extras", but 

http://fedora.redhat.com/packages is 404.


Comment 3 Patrick Barnes 2005-11-15 20:33:09 UTC
Has any progress been made on this front?  It looks like this has been
forgotten.  It would certainly be nice to have this.

On a slightly related note, Thomas Chung, Seth Vidal, Luke Macken and myself
have discussed adding a listing like the one available at
http://fedoranews.org/mediawiki/index.php/Fedora_Updates to fedoraproject.org. 
This would provide users a list of packages that have been updated.


Comment 4 Alex Lancaster 2005-11-28 13:37:36 UTC
Looks like Extras repoview packages have either been dropped and/or are missing,
see: bug #174357.

Comment 5 Rahul Sundaram 2006-01-23 01:31:54 UTC
Jesse Keating added a repoview for Fedora devel repository. When it reaches FC5
we would have one for core too. I am closing this report. Thank you. 

Comment 6 Alex Lancaster 2006-01-23 08:27:34 UTC
(In reply to comment #5)
> Jesse Keating added a repoview for Fedora devel repository. When it reaches FC5
> we would have one for core too. I am closing this report. Thank you. 

Which happens to be here, just had to hunt around for the URL... ;-)

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/repodata/

Thanks.

Comment 7 Alex Lancaster 2006-02-15 22:59:33 UTC
Repoview has disappeared from:

http://download.fedora.redhat.com/pub/fedora/linux/core/development/i386/repodata/

Re-opening bug.

Comment 8 Jesse Keating 2006-02-15 23:05:42 UTC
repoview broke for a bit when yum's comps handling changed.  This has been fixed
and repoview has been turned back on.

Comment 9 Alex Lancaster 2006-02-15 23:11:05 UTC
(In reply to comment #8)
> repoview broke for a bit when yum's comps handling changed.  This has been fixed
> and repoview has been turned back on.

When will it re-appear on the site?

Comment 10 Jesse Keating 2006-02-15 23:14:26 UTC
The next time rawhide pushes.


Note You need to log in before you can comment on or make changes to this bug.