Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161900 - gnome-terminal: ability to save scrollback to a file
Summary: gnome-terminal: ability to save scrollback to a file
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dams
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 161902 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 10:45 UTC by Need Real Name
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-08-02 18:43:06 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 24457 None None None Never

Description Need Real Name 2005-06-28 10:45:09 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.3

Description of problem:
This is a gnome-terminal RFE.

The ability to save scrollback to a file would be more than useful.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
x

Additional info:

Comment 1 Need Real Name 2005-06-28 10:49:32 UTC
*** Bug 161902 has been marked as a duplicate of this bug. ***

Comment 2 Need Real Name 2005-12-01 15:11:31 UTC
Any chance of getting this into FC5? Rolling through 25000 lines of scrollback
to do a copy and paste is awful.

Comment 3 Matthias Clasen 2006-08-02 18:43:06 UTC
Feature requests like this are much better tracked upstream in bugzilla.gnome.org.
But in this particular case, I think you should just use the existing "script"
command.

Comment 4 Need Real Name 2006-08-04 18:59:44 UTC
Can you give an example of this script command to do this... :)

Reported upstream.

Comment 5 Need Real Name 2006-08-04 21:11:40 UTC
Ugh. Sorry. I thought you meant gnome-terminal had some kind of scripting
interface, I didn't realise you meant script as in "script".

I can't use script, since I don't know when I want to be logging the terminal
sessions.


Note You need to log in before you can comment on or make changes to this bug.