Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161890 - Unable to login as admin to configure my Login manager in kcontrol
Summary: Unable to login as admin to configure my Login manager in kcontrol
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kdebase
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ngo Than
QA Contact: Ben Levenson
URL: Kcontrol >> Login Manager >> Cannot e...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-28 07:34 UTC by Rohith V
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 08:00:39 UTC


Attachments (Terms of Use)

Description Rohith V 2005-06-28 07:34:59 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
I launched kcontrol. I selected "Login Manager". I wanted to configure my Login manager so I clicked on "Administrator Mode" tab. It prompts for password and I did enter a valid password. The password dialog box accepts and vanishes, but I am still in "Login Manager" as a non-admin. Hence I cannot configure any of the features in the "Login Manager". This is a consistent behaviour on my system. Some  times after I enter the password I see a totally different screen i.e the right side frame which initially shows all system administrator configurable features and a theor description, will jump to say "Internet & Network".

Version-Release number of selected component (if applicable):
kdebase-3.4.0-5

How reproducible:
Always

Steps to Reproduce:
1. Launch kcontrol
2. Choose Login Manager
3. Click on "Administrator Mode". It prompts for password.
4. Enter password and press enter.
5. The password is accepted but I am still in non-admin mode.
  

Actual Results:  I am not logged in as admin and hence cannot configure any features of "Login Manager". Sometimes it jumps to a totally different option in kcontrol.

Expected Results:  I should have been logged in as admin with the right frame bordered in "RED"

Additional info:

Comment 1 Ngo Than 2005-06-28 08:00:39 UTC
It's not reproduceable in FC4 with KDE updates.


Comment 2 Rohith V 2005-07-11 13:34:46 UTC
Yes, I did an yum upgrade on kdebase and it works for me now.


Note You need to log in before you can comment on or make changes to this bug.