Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161858 - Unable to obtain IP-address whit kernel 2.6.11-1.35_FC3
Summary: Unable to obtain IP-address whit kernel 2.6.11-1.35_FC3
Keywords:
Status: CLOSED CANTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 21:18 UTC by Truls Gulbrandsen
Modified: 2014-03-17 02:54 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-09-18 19:26:02 UTC


Attachments (Terms of Use)

Description Truls Gulbrandsen 2005-06-27 21:18:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Fedora/1.0.4-1.3.1 Firefox/1.0.4

Description of problem:
After upgrading to kernel 2.6.11-1.35_FC3 I was unable to obtain IP-address.  Loading with the previous kernel made everything work as normal.

A workaround was found in the Fedora-list:

On Mon, 2005-06-27 at 13:29, Truls Gulbrandsen wrote:

>> -----BEGIN PGP SIGNED MESSAGE-----
>> Hash: SHA1
>> 
>> Hi,
>> after updating the kernel I am no longer able to obtain an IP-adress
>> from my router.  Loading the previous kernel makes everything working fine.
>> 
>> My configuration is an IBM TP T23 with a Cisco 350 Series PCMCIA Wlan card.
>> 
>> Does anyone have an ide for a different workaround or should I wait for
>> the next kernel update?


Try deleting the CHANNEL line (or comment it out) in the ifcfg file.  I
have experienced a problem with ipw2200bg chipset where that appears to
be a possible fix.  Was able to see the access points but the card was
never able to establish a connection and get an IP address.

Suspect this points to a fundamental flaw in how the wireless cards are
handled by the system.

-- Scot L. Harris webid@cfl.rr.com 

Version-Release number of selected component (if applicable):
2.6.11-1.35_FC3

How reproducible:
Always

Steps to Reproduce:
1. boot FC3 with kernel 2.6.11-1.35_FC3 without commenting out CHANNEL in in ifcfg
2.
3.
  

Actual Results:  I was unable to obtain IP-address from the router, however, kwifimanager showed that I had contact with it.

Expected Results:  I should have received an IP-address.

Additional info:

Comment 1 Dave Jones 2005-06-27 21:37:35 UTC
There were no IPW changes in the last kernel update (nor have there been for
some time in FC3).  Additionally, this sounds more like a configuration problem
than a driver bug.


Comment 2 Truls Gulbrandsen 2005-06-28 18:42:45 UTC
Please tell me, how can this be a configuration problem when everything works
using kernel 2.6.11-1.27_FC3 but fails using kernel 2.6.11-1.35_FC3 without any
other changes?

Does applying the work-around, commenting out the CHANNEL line, have any
negative consequence to my system?

Truls

Comment 3 Harald Hoyer 2005-06-29 12:06:34 UTC
This seems to be a change within the driver... 
If this behaviour is considered standard, then 
$ rpm -qf /etc/sysconfig/network-scripts/ifup-wireless
initscripts-8.11.1-1

should be corrected

Comment 4 Dave Jones 2005-07-05 19:37:45 UTC
See comment #1.

"There were no IPW changes in the last kernel update"


Comment 5 Bill Nottingham 2005-07-05 20:23:05 UTC
If channel is not needed, then it probably shouldn't be in the config file; why
was it specified beforehand?

Comment 7 Bill Nottingham 2007-09-18 19:26:02 UTC
Closing this bug - FC3 is older and no longer supported. Please reopen if this
persists on a current release. Apologies for the delay.


Note You need to log in before you can comment on or make changes to this bug.