Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161832 - Abiword is not loading certain modules
Summary: Abiword is not loading certain modules
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: abiword
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Marc Maurer
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 170984 (view as bug list)
Depends On:
Blocks: FE5Target
TreeView+ depends on / blocked
 
Reported: 2005-06-27 16:43 UTC by Toshio Kuratomi
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.4.1-2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-10-23 13:33:49 UTC


Attachments (Terms of Use)

Description Toshio Kuratomi 2005-06-27 16:43:33 UTC
Description of problem:
Abiword will not load or save docbook files.  The option does not appear in the 
save as dialog.  Investigating ~/.AbiSuite/AbiWord.Profile shows the following
plugins failed to load:

        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiXSLFO.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiXSLFO.so -->        <!-- [Mon 27 Jun 2005
11:06:37 AM EDT] message: XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiXSLFO.so: undefined symbol: __dso_handle -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiOpenWriter.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiOpenWriter.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiOpenWriter.so: undefined symbol:
__dso_handle -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiHRText.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiHRText.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiHRText.so: undefined symbol: __dso_handle -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiGimp.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiGimp.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiGimp.so: undefined symbol:
_Z10progExistsPKc -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiDocBook.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiDocBook.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiDocBook.so: undefined symbol: __dso_handle -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L129): loading
/usr/lib64/AbiWord-2.2/plugins/libAbiAikSaurus.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L168): failed to load
/usr/lib64/AbiWord-2.2/plugins/libAbiAikSaurus.so -->
        <!-- [Mon 27 Jun 2005 11:06:37 AM EDT] message:
XAP_ModuleManager::loadModule - (L174): error msg
/usr/lib64/AbiWord-2.2/plugins/libAbiAikSaurus.so: undefined symbol:
__dso_handle -->


Version-Release number of selected component (if applicable):
abiword-2.2.8-1
kernel-2.6.11-1.1369_FC4
glibc-2.35-10
Fedora Core 4 + Updates

How reproducible:
Always

Steps to Reproduce:
1. Start Abiword
2. Close abiword
3. Look in ~/.AbiSuite/AbiWord.Profile 
  
Actual results:
Find failures loading the docbook and other plugins.

Expected results:
Plugins load and I can load and save docbook files.


Additional info:
This is on an x86_64 system.  Haven't tested on any other archs yet.

Comment 1 Marc Maurer 2005-10-17 12:49:17 UTC
*** Bug 170984 has been marked as a duplicate of this bug. ***

Comment 2 Marc Maurer 2005-10-23 13:33:49 UTC
Fixed in abiword-2.4.1-2.fc4. Should hit the yum repository soonish.


Note You need to log in before you can comment on or make changes to this bug.