Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161824 - gnome-pilot doesn't work properly with shipped pilot-link
Summary: gnome-pilot doesn't work properly with shipped pilot-link
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-pilot
Version: 4
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 16:09 UTC by Mark Adams
Modified: 2007-11-30 22:11 UTC (History)
12 users (show)

Fixed In Version: gnome-pilot-2.0.15-1.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-02 15:12:32 UTC


Attachments (Terms of Use)
Update gnome-pilot for latest pilot-link API (deleted)
2005-06-27 16:10 UTC, Mark Adams
no flags Details | Diff
Update porting patch to fix bugs in param checks (deleted)
2005-07-21 02:16 UTC, Mark Adams
no flags Details | Diff

Description Mark Adams 2005-06-27 16:09:32 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
gnome-pilot as shipped doesn't work with the shipped pilot-link. See http://bugzilla.gnome.org/show_bug.cgi?id=274032 for all the gory details.

The attached patch updates gnome-pilot to work with the latest pilot-link API, and replaces the gnome-pilot-2.0.12-port-to-pilot-link-0.12.patch patch included in the .spec file.

Note that the patch presupposes the memory leak patch at http://bugzilla.gnome.org/show_bug.cgi?id=309077 although they're quite independent.



Version-Release number of selected component (if applicable):
gnome-pilot-2.0.13-2

How reproducible:
Always

Steps to Reproduce:
Try to sync. Watch it fail.


Additional info:

Comment 1 Mark Adams 2005-06-27 16:10:12 UTC
Created attachment 116025 [details]
Update gnome-pilot for latest pilot-link API

Comment 2 V. Varadhan 2005-07-01 10:41:15 UTC
You may want to bump the pilot-link-version in configure to 0.12.preXXX, as this
patch doesn't compile successfully on pilot-link-version 0.11.xx.

Comment 3 Mark Adams 2005-07-21 02:15:35 UTC
I found a couple more bugs in the patch porting gnome-pilot to pilot-link 0.12,
so have re-created the patch and will attach below. In particular, the
gnome_pilot_compat_with_pilot_link_0_11 routines in
gpilotd/gnome-pilot-conduit-standard-abs.c had an incorrect check for the size
parameter being non-null, and was thus leading to uninit mem being used in
gnome-pilot-conduits (and some rather impressive crashes as it tried to allocate
a couple of gig of ram).


Comment 4 Mark Adams 2005-07-21 02:16:57 UTC
Created attachment 117005 [details]
Update porting patch to fix bugs in param checks

Comment 5 Mark Smith 2005-10-06 20:29:41 UTC
Any idea when these patches will make it into FC4 updates?  I just "yum
check-update; yum update" yesterday and this is still very broken.

Comment 6 David A. Cafaro 2005-10-11 18:37:37 UTC
Another person here waiting for a working sync in FC4.  When is this slated to
upstream?  Thanks.

Comment 7 Thomas J. Baker 2005-10-24 20:19:34 UTC
I'm having no luck with a LifeDrive, FC4 x86_64, and gnome-pilot. I've rebuilt
the gnome-pilot in updates-testing with the second patch provided by Mark above
but I still get this error:

(gpilotd:29010): gpilotd-WARNING **: An error occured while getting the pilot's
system data

I can get syncing (at least backup) working on my laptop with FC4 (i686) but
that's not where I want to sync so it seems I'm having an x86_64 problem. Any ideas?

Comment 8 Gilboa Davara 2005-10-25 06:23:38 UTC
Try creating a dev entry under /etc/dev using mknod. At least in my case, it
solved the problem.

Comment 9 Thomas J. Baker 2005-10-25 12:21:54 UTC
I tried that with a device in my home directory but it didn't help. I believe
the newer gnome-pilot in updates-testing deals with the slow creation of the
device. This seems to be a problem after communication has begun.

Comment 10 Thomas J. Baker 2005-10-25 15:28:06 UTC
I actually have got network syncing working sporadically now with the LifeDrive.
I have hand modified the /.gnome2/gnome-pilot.d/gpilotd file to include 

[Device0]
type=1
name=LifeDrive
device=net:any
speed=115200
timeout=10

and syncing now seems to work sometimes. I had trouble repeating a sync but
after restoring the usb sync config directives, having that fail like #7 above,
and restoring the network sync config directives, I was able to repeat a sync.

So the error from #7 seems to be a communication problem as opposed to a
gpilotd-hating-lifedrives problem.


Comment 11 Matt Davey 2006-01-05 12:55:54 UTC
See my comment on #172670:
I think this issue is rooted in pilot-link post July 20th (as shipped in the
pilot-link-0.12.0-0.pre4.0.fc4.2 package).
The issue _may_ be helped by setting a timeout=0 in the configuration.

The reason the config in comment #10 'works' is that it bypasses the
serial code in pilot-link, by using a network sync.  By the way, I assume that
Thomas J. Baker can only use his workaround with a usb-connected device?
That would be because network syncing is not working properly at present in
gnome-pilot, and it needs the usb wakeup before passing the 'net:any' string
to pilot-link to connect via the network.

Comment 12 Thomas J. Baker 2006-01-05 13:19:35 UTC
Yes, exactly true. It was working sporadically until I realized that I had to
attach the LifeDrive to the USB connector. Then it works, mostly, except when
you want to restore from backup :-(

Comment 13 Sergio 2006-02-11 22:29:32 UTC
WorksForMe using the packages from FC4 updates-testing:
gnome-pilot-2.0.13-5.fc4
gnome-pilot-conduits-2.0.13-1
evolution-2.2.3-3.fc4

Zire (m150) + FC4 PPC on iBook G3 600 (PowerBook4,1)
kernel 2.6.15-1.1831_FC4
full package update on 2006-02-12 (from stable updates)

Great job - thanks a lot !!!

Comment 14 Matthew Barnes 2006-07-31 14:43:29 UTC
Is this bug still present in the latest Rawhide release?

evolution-2.7.4-3
gnome-pilot-2.0.13-13.1
gnome-pilot-conduits-2.0.13-6.1

Comment 15 Matthew Barnes 2007-01-02 15:12:32 UTC
Closing per comment #13 and lack of response for updated status.  Feel free to
re-open this bug if you still encounter the problem in Fedora Core 6 or later.


Note You need to log in before you can comment on or make changes to this bug.