Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161820 - Build writes to destination location, not %_tmppath
Summary: Build writes to destination location, not %_tmppath
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: xcin
Version: 4.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Caius Chance
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 15:54 UTC by Steve Snyder
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-03-23 03:59:31 UTC


Attachments (Terms of Use)
local build log (deleted)
2007-03-23 03:03 UTC, Caius Chance
no flags Details

Description Steve Snyder 2005-06-27 15:54:14 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050520 Fedora/1.7.8-1.icc

Description of problem:
In the course of rebuilding this package, the files to be packaged are written to /usr/X11R6/lib/X11/xcin/, their final location.  The files should be written to %_tmppath/xcin-buildroot/usr/X11R6/lib/X11/xcin/ prior to packaging.


Version-Release number of selected component (if applicable):
xcin-2.5.3.pre3-24

How reproducible:
Didn't try

Steps to Reproduce:
1.Run: rpmbuild --rebuild xcin-2.5.3.pre3-24.src.rpm
2.Build fails because the files are not in the expected location
3.
  

Actual Results:  The contents of /usr/X11R6/lib/X11/xcin/ are ovewritten by the files to be packaged, then the packaing fails because the files are not found in the correct location.

Expected Results:  The file to be packaged should be written beneath %_tmppath/xcin-buildroot/.

Additional info:

A request: please do test builds on a system with /usr mounted read-only.  I'm seeing way too many RHEL4 package builds that erroneously write to a directory beneath /usr in the course of the processing.  Only directories beneath %_tmppath and %_builddir should be written to during a package build.  Mounting /usr as read-only would let you catch these spec file mistakes before your customers do.  Thanks.

Comment 1 Caius Chance 2007-03-23 03:03:02 UTC
Created attachment 150719 [details]
local build log

Test built on a system with /usr/X11R6/lib/X11/xcin as a read-only empty file.
- SUCCESS

OS: RHEL4-U5 (beta)
Package: xcin-2.5.3.pre3-25


Note You need to log in before you can comment on or make changes to this bug.