Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161818 - Kernel panic after FC4 install on AMD Athlon K7
Summary: Kernel panic after FC4 install on AMD Athlon K7
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: athlon
OS: Linux
medium
high
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 15:50 UTC by Sam
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version: kernel 1447_FC4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-30 14:42:00 UTC


Attachments (Terms of Use)

Description Sam 2005-06-27 15:50:37 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.8) Gecko/20050511 Firefox/1.0.4

Description of problem:
On two different systems, I have had immediate, or intermittent, kernel panic crashes, in both cases on AMD Athlon K7 processors.  The first case, an AMD-K7 1100, on an ASUS A7V-E motherboard, the installer kernel paniced several times, but I managed to finish the install.  After that, the system kernel panic crashed intermittently.  After swapping boards and to an Intel CPU, that FC4 system has run flawlessly.  The other case is an AMD-K7 550 on an FIC SD11 motherboard, in which case the install ran fine but the system kernel panics upon first boot; the crash dump looks very similar to the one on the 1100 system.  My conclusion is that the installer kernel with FC4 crashes on Athlon K7 systems.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1369_FC4

How reproducible:
Always

Steps to Reproduce:
1. Run upgrade OR install of FC4 on an Athlon K7 system.
2. If no kernel crash on install, wait up to 24 hours.  No FC4/K7 system has stayed up that long here.
3.
  

Actual Results:  Kernel panic, with large screen dump, unable to copy since on console only and machine is frozen.

Expected Results:  No crash.

Additional info:

SAME system works fine on a Celeron system.  Simple motherboard swap and ran installer to make new initrd, booted right up, stable ever since.

Comment 1 Dave Jones 2005-07-08 01:01:36 UTC
please capture that screen dump (even if its a digital camera pic), without it,
we've no chance of chasing this problem.


Comment 2 Sam 2005-07-08 14:35:33 UTC
Will do, Dave, I'll grab a free HD and try to get as much of it with a camera
that I can.  There's no predicting when it'll happen, so I think it's hopeless
to try to stop the screen scroll, so it'll only be the tail 25 lines, may not be
useful.

Comment 3 Dave Jones 2005-07-15 21:46:01 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak
kudzu


Thank you.


Comment 4 Dave Jones 2005-09-30 07:18:11 UTC
Mass update to all FC4 bugs:

An update has been released (2.6.13-1.1526_FC4) which rebases to a new upstream
kernel (2.6.13.2). As there were ~3500 changes upstream between this and the
previous kernel, it's possible your bug has been fixed already.

Please retest with this update, and update this bug if necessary.

Thanks.


Comment 5 Sam 2005-09-30 14:42:00 UTC
Yes, Dave, actually this bug was fixed in kernel build 1447_FC4, and I was
remiss in updating this bug (actually thought I had).  My apologies for that. 
I've been running 1447_FC4 on the very machine that exhibited the problem with
the FC 4 install kernel, and it's been flawless for a couple weeks now.  Thanks!


Note You need to log in before you can comment on or make changes to this bug.