Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161798 - Some applets (clock, kbd indicator) invisible on dark or transparent panel background
Summary: Some applets (clock, kbd indicator) invisible on dark or transparent panel ba...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets
Version: 6
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 14:16 UTC by Petr Tuma
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-08-15 18:18:55 UTC


Attachments (Terms of Use)

Description Petr Tuma 2005-06-27 14:16:10 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When the panel background is set to a dark color or made transparent on a dark desktop background, some applets become invisible. This concerns notably the clock applet, keyboard indicator applet, battery applet.

There appears to be a difference in how various applets handle dark panel background. Some adopt the background, some remain on system background. It is hard to tell what is correct but when an applet chooses to adopt the background, it should adjust the font color to something contrasting ...

Note that this also concerns the buttons on the edges of a panel that is not expanded, they remain the default color no matter what the background. This pretty much makes it impossible to make a normally looking panel on a black background, because a lot of default colored artifacts remains no matter what the background settings.

There used to be the same problem in earlier releases of Fedora (FC3 Beta ?) but it did not exist in the latest FC3 packages.


Version-Release number of selected component (if applicable):
gnome-applets-2.10.1-9

How reproducible:
Always

Steps to Reproduce:
1. Create Gnome Panel
2. Put Clock Applet on the panel
3. Open preference dialog of the panel
4. Select Solid Color, Black (or Transparent on Black background)
5. Notice the clock becoming unreadable
6. Try the same with keyboard indicator and battery applet with time or percentage displayed

Actual Results:  The clock becomes unreadable, being displayed in black font on black background.


Expected Results:  Either the clock should select the font color automatically to be readable, or the color should be configurable in preferences.


Additional info:

Comment 1 Petr Tuma 2006-10-27 19:44:52 UTC
Retested on FC6, the problem still persists.


Comment 2 Ray Strode [halfline] 2007-08-15 18:18:55 UTC
This is actually kind of a hard problem to solve.   There is some upstream work
on this front in gtk to make this easier, but I can't find the bugs off hand.
Anyway,  fixing this type of thing is some ways off, so I'm going to go ahead
and close this DEFERRED


Note You need to log in before you can comment on or make changes to this bug.