Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161786 - RPM signing error
Summary: RPM signing error
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: bitmap-fonts
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 11:23 UTC by James Wilkinson
Modified: 2013-03-06 03:43 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-29 21:48:01 UTC


Attachments (Terms of Use)

Description James Wilkinson 2005-06-27 11:23:19 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.8) Gecko/20050511

Description of problem:
[root@kendrick RPMS]# rpm --checksig [bc]*
bitmap-fonts-0.3-4.noarch.rpm: (SHA1) DSA sha1 md5 (GPG) NOT OK (MISSING KEYS: GPG#db42a60e)
compat-db-4.2.52-2.i386.rpm: (sha1) dsa sha1 md5 gpg OK
compat-db-4.2.52-2.x86_64.rpm: (sha1) dsa sha1 md5 gpg OK

[root@kendrick RPMS]# rpm -i bitmap-fonts-0.3-4.noarch.rpm
warning: bitmap-fonts-0.3-4.noarch.rpm: Header V3 DSA signature: NOKEY, key ID db42a60e

This means I can't download or install this through yum: yum gives the same error and won't proceed (sorry, the terminal crashed, so I can't give a script).

I have done
rpm --install /etc/pki/rpm-gpg/RPM-GPG-KEY*
and 
gpg --import /etc/pki/rpm-gpg/RPM-GPG-KEY*
and yum's done this, too. The problem persists.

Am I being stupid?

Version-Release number of selected component (if applicable):
bitmap-fonts-0.3-4

How reproducible:
Always

Steps to Reproduce:
The only obvious setup step is that I started with a minimal install.

Additional info:

RPM above is on a loop-back mounted ISO image downloaded through bittorrent. YUm result is reproducable: I haven't edited anything under /etc/yum* yet.

Suggest that this package normally gets installed at system install, where keys are ignored, so most people won't notice this.

Comment 1 John Mahowald 2005-07-29 21:48:01 UTC
Works for me, try  "rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY*"


Note You need to log in before you can comment on or make changes to this bug.