Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161783 - kernel 2.6.11-1.35_FC3
Summary: kernel 2.6.11-1.35_FC3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 10:37 UTC by Eric PLETAN
Modified: 2015-01-04 22:20 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-05 06:39:59 UTC


Attachments (Terms of Use)

Description Eric PLETAN 2005-06-27 10:37:47 UTC
Description of problem:
With Red Hat Network I have installed the last update of kernel
(2.6.11-1.35_FC3) yesterday (26 june).
I have an automatic start for Apache and Oracle.
When I boot the machine I have the following error : error while loading shared
libraries: /u01/oracle/product/10.1.0/Db_1/lib/libnnz10.so: cannot restore
segment prot after reloc: Permission denied
So, I cannot start the listener for Oracle and I cannot start apachectl.
I think that it's a problem with the last kernel update (2.6.11-1.35_FC3)
because before that install it was OK.

Version-Release number of selected component (if applicable):
My previous version was : 2.6.11-1.27_FC3 (no problem)
My actual version is : 2.6.11-1.35_FC3

How reproducible:
I have Oracle 10.1.0, Apache httpd 2.0.54 et PHP 4.3.11
Apache configuration : --enable-so
PHP configuration : --with-apxs2=/usr/local/apache2/bin/apxs --with-oci8

Steps to Reproduce:
1. Install Oracle 10.1.0 and try to start listener (lsnrctl start)
2. Or try to start Apache (apachectl start)
3.
  
Actual results:
Listener Oracle :
/u01/oracle/product/10.1.0/Db_1/bin/lsnrctl: error while loading shared
libraries: /u01/oracle/product/10.1.0/Db_1/lib/libnnz10.so: cannot restore
segment prot after reloc: Permission denied
Apache httpd :
Cannot load /usr/local/apache2/modules/libphp4.so into server:
/u01/oracle/product/10.1.0/Db_1/lib/libnnz10.so: cannot restore segment prot
after reloc: Permission denied
Re-install PHP :
/usr/local/php-4.3.11/sapi/cli/php: error while loading shared libraries:
/u01/oracle/product/10.1.0/Db_1/lib/libnnz10.so: cannot restore segment prot
after reloc: Permission denied


Expected results:


Additional info:

Comment 1 Dave Jones 2005-07-08 00:59:39 UTC
echo 1 > /proc/sys/kernel/exec_shield should get you up and running again.

This is being corrected in the next errata kernel for FC3.



Note You need to log in before you can comment on or make changes to this bug.