Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161782 - mock init misses /sbin/runuser
Summary: mock init misses /sbin/runuser
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: mock
Version: 4
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Seth Vidal
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 10:11 UTC by Ralf Corsepius
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 14:39:42 UTC


Attachments (Terms of Use)
root.log of the failing mock init (deleted)
2005-06-27 13:41 UTC, Ralf Corsepius
no flags Details

Description Ralf Corsepius 2005-06-27 10:11:57 UTC
"mock .. init" fails because /sbin/runuser (coreutils) is missing inside of the
chroot:

Using /etc/mock/fedora-4-i386-core, from FE's CVS, with a user-id 601:

# mock -rfedora-4-i386-core init
Starting Prep
Preparing Root
making /dev devices
making misc files of use
making yum.conf
yum: command /usr/sbin/mock-helper yum --installroot
/var/lib/mock/fedora-4-i386-core/root groupinstall build
Creating user for builds
Closed
Non-zero return value 127 on executing /usr/sbin/mock-helper chroot
/var/lib/mock/fedora-4-i386-core/root /sbin/runuser - root -c "/usr/sbin/useradd
-u 601 -d /builddir mockbuild"

Version-Release number of selected component (if applicable):
mock-0.3-2.fc4

How reproducible:
Deterministic

This bug render mock completely unusable.

Comment 1 Seth Vidal 2005-06-27 13:13:08 UTC
attach the root.log from the resultdir of this chroot init.



Comment 2 Ralf Corsepius 2005-06-27 13:41:39 UTC
Created attachment 116012 [details]
root.log of the failing mock init

Comment 3 Seth Vidal 2005-06-27 14:39:42 UTC
turn selinux off AND edit /etc/selinux/config to set it to be disabled.

or
wait for mock 0.4


it's not a bug in mock 0.3 b/c selinux was not supported there.

Comment 4 Ralf Corsepius 2005-06-27 14:59:49 UTC
Seth, inIMO, this mock package shou(In reply to comment #3)
> turn selinux off AND edit /etc/selinux/config to set it to be disabled.
> 
> or
> wait for mock 0.4
> 
> 
> it's not a bug in mock 0.3 b/c selinux was not supported there.

In this case I would recommend you to withdraw mock from FE4.
FE should not be a place for experiments with unstable packages.

Comment 5 Seth Vidal 2005-06-27 15:00:48 UTC
there is no unstability. It's just not supporting selinux.

relax - it's not a big deal.



Comment 6 Ralf Corsepius 2005-06-27 15:06:46 UTC
(In reply to comment #5)
> there is no unstability. 
With all due respect, Seth, I could not disagree much more.

> It's just not supporting selinux. relax - it's not a big deal.
I have to disagree again. I am inclined to think you are mixing up "wishful
thinking" with reality.

IMO, package inside of FE must work "out of the box", otherwise there should not
be any room for these packages inside of FE.

To me, this package having made it into FE is clear QA failure.



Comment 7 Seth Vidal 2005-06-27 15:07:41 UTC
That's nice. I don't really care.

HAND



Note You need to log in before you can comment on or make changes to this bug.