Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161781 - hal shows incorrect label for hd
Summary: hal shows incorrect label for hd
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: hal
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Zeuthen
QA Contact:
URL:
Whiteboard:
: 161778 161779 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 09:55 UTC by drago01
Modified: 2013-03-06 03:43 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-29 17:02:53 UTC


Attachments (Terms of Use)
output of lshal (deleted)
2005-06-27 09:59 UTC, drago01
no flags Details

Description drago01 2005-06-27 09:55:44 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; de-DE; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When I browse "Computer" in nautilus the label of hdb1 is shown as d>
hal-device-manager shows it as:
 d>
</tr>
";
this also happen in the gtk file selector
hda1 (ntfs) is shown as 104 GB Medium wich is correct.
filesystem on hdb1 is vfat.

Version-Release number of selected component (if applicable):
hal-0.5.2-2

How reproducible:
Always

Steps to Reproduce:
1. look at the device label using any app that uses hal

  

Actual Results:  incorrect device label is shown

Expected Results:  correct device label should be shown

Additional info:

I found this in /var/log/messages:
Jun 27 11:50:51 chello062178124144 kernel: audit(1119865851.791:2): avc:  denied  { write } for  pid=3221 comm="hald" name=[22459] dev=pipefs ino=22459 scontext=root:system_r:hald_t tcontext=root:system_r:unconfined_t tclass=fifo_fil

Comment 1 drago01 2005-06-27 09:59:49 UTC
Created attachment 116005 [details]
output of lshal

Comment 2 drago01 2005-06-27 11:22:49 UTC
*** Bug 161778 has been marked as a duplicate of this bug. ***

Comment 3 drago01 2005-06-27 11:23:22 UTC
*** Bug 161779 has been marked as a duplicate of this bug. ***

Comment 4 drago01 2005-06-27 11:24:12 UTC
sorry for the reporting it 3 times dunno what happend

Comment 5 drago01 2005-06-28 05:55:33 UTC
I tryed everything to find out why and how this happen but could not find anything.
tryed hdb=noprobe and reboot -> nothing
reinstalled hal -> nothing
downloaded hal source and searched in them -> nothing
tryed fsck.vfat -> nothing
tryed to repiar the filesystem using windows -> nothing
...
whats going on?
any hint how this can be fixed or how I can provide more info?
the partition has now label.
here is the smartctl output for the device.
----
smartctl --info /dev/hdb
smartctl version 5.33 [i386-redhat-linux-gnu] Copyright (C) 2002-4 Bruce Allen
Home page is http://smartmontools.sourceforge.net/

=== START OF INFORMATION SECTION ===
Device Model:     ST340823A
Serial Number:    6EF0CAAP
Firmware Version: 3.05
User Capacity:    40,016,019,456 bytes
Device is:        In smartctl database [for details use: -P show]
ATA Version is:   4
ATA Standard is:  Exact ATA specification draft version not indicated
Local Time is:    Tue Jun 28 07:50:23 2005 CEST
SMART support is: Available - device has SMART capability.
SMART support is: Enabled
-----

Comment 6 drago01 2005-06-28 06:00:28 UTC
fdisk -l /dev/hdb

Disk /dev/hdb: 40.0 GB, 40016019968 bytes
255 heads, 63 sectors/track, 4865 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

   Device Boot      Start         End      Blocks   Id  System
/dev/hdb1               1        4864    39070048+   c  W95 FAT32 (LBA)


Comment 7 drago01 2005-06-28 08:54:44 UTC
the selinux warning does only happen if i restart hald on boot selinux does not
show any errors... so it isn't an selinux issue

Comment 8 drago01 2005-06-29 17:02:53 UTC
deleting the partition and recreating it solved the problem.


Note You need to log in before you can comment on or make changes to this bug.