Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161759 - Installer hangs loading USB module
Summary: Installer hangs loading USB module
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 4
Hardware: i386
OS: Linux
Target Milestone: ---
Assignee: Pete Zaitcev
QA Contact: Brian Brock
Depends On:
TreeView+ depends on / blocked
Reported: 2005-06-27 01:55 UTC by Wayne Carruthers
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Last Closed: 2005-09-30 23:52:23 UTC

Attachments (Terms of Use)

Description Wayne Carruthers 2005-06-27 01:55:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Win95; en-US; rv:1.7.3) Gecko/20040910

Description of problem:
Installer hangs at USB module load & does not recover or time-out when installing onto a PC Chips M925 motherboard

By way of background the M925 is a P4 Socket 478 all in one motherboard using VIA P4M266A Northbridge & VT8235 Southbridge

The system concerned has FC3 installed & is still fully operational & patched to latest updates. This clean install to another partition was to test FC4
Tried an upgrade & same result

A similar problem occurs with this MBoard installing Gentoo 2005 which loses the interrupt for LAN (finds LAN then later reports interrupt "ignored, no one cares") Gentoo 2004/1 & 2 also loads/runs OK

Suspect it is to do with a newer handler for the VIA chipset but not sure what further data to provide to assist in determining cause.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Install from distribution CD

Actual Results:  HANGS

Additional info:

Comment 1 Pete Zaitcev 2005-06-27 21:01:54 UTC
Before I take this, I need to know if this is USB or some generic problem
with interrupts routing, interrupt storm, or other.

Please install an FC4 kernel on top of working FC3 with rpm -i (do not use
rpm -U), and verify that it fails.

Comment 2 Wayne Carruthers 2005-06-28 02:35:52 UTC
Installed FC4 Kernel as per request and all ok, boots, USB,LAN etc all operational
No errrors onscreen during boot

Had to remove selinux policy prior to kernel install due error shown below

rpm -i kernel*.rpm
error: Failed dependencies: selinux-policy-targeted < 1.23.16-1 conflicts with
kernel-2.6.11-1.1369_ FC4.i686

Let me know what other tests I can do to assist

Comment 3 Wayne Carruthers 2005-06-28 05:10:37 UTC
Went back & looked closer

Deactivated USB in BIOS & ran clean install to spare partition, all ran OK
reboot & complete firstboot all ok, reactivated USB in BIOS & reboot, all OK
Kudzu did not pop up & say new hardware, but USB configured & working

Ran installer again with USB active & it gets to the blue screen driver install
stage, says loading usb-storage driver, goes to loading aic7xxx driver, then
returns to loading usb-storage driver screen & hangs

It seems the problem is in the installer script only and is a conflict between
the aix7xxx driver for our Adaptec 2940 SCSI card & the USB, which does not
happen in the FC3 install, nor happen post install with all active

System now happily upgraded with USB deactivated during install, SCSI, scanner &
USB reactivated & all OK

Have spare partition for further tests if I can be of assistance in proving any
 installer script changes

Comment 4 Dave Jones 2005-07-15 21:50:10 UTC
[This comment has been added as a mass update for all FC4 kernel bugs.
 If you have migrated this bug from an FC3 bug today, ignore this comment.]

Please retest your problem with todays 2.6.12-1.1398_FC4 update.

If your problem involved being unable to boot, or some hardware not being
detected correctly, please make sure your /etc/modprobe.conf is correct *BEFORE*
installing any kernel updates.
If in doubt, you can recreate this file using..

mv /etc/sysconfig/hwconf /etc/sysconfig/hwconf.bak
mv /etc/modprobe.conf /etc/modprobe.conf.bak

Thank you.

Note You need to log in before you can comment on or make changes to this bug.