Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161753 - Nscd cache seems to invalidate itself in certain scenarios
Summary: Nscd cache seems to invalidate itself in certain scenarios
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: glibc
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-27 00:51 UTC by W. Michael Petullo
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 14:55:44 UTC


Attachments (Terms of Use)

Description W. Michael Petullo 2005-06-27 00:51:18 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux ppc; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.6.3

Description of problem:
I have a test network containing a network information server that provides an LDAP service.  

On the network, I have a laptop client that uses LDAP to lookup GIDs for group names.  The laptop is using pam_ccreds to cache authentication information and nscd to cache other information.  All of the nscd services have a very high time-to-live.

My use of pam_ccreds and nscd is to ensure that the laptop is usable away from the network.

Version-Release number of selected component (if applicable):
nscd-2.3.5-11

How reproducible:
Always

Steps to Reproduce:
There are three scenarios I have been using to try and figure out what is wrong.

Scenario 1: I turn on my laptop when it is connected to my network and my LDAP server is available.  In this case, "id -ng" says, "mike."  This is my test account's default group.  This is good.

Scenario 2: I turn on my laptop when it is disconnected from any network.  In this case, "id -ng" says, "mike."  This is also good.

Scenario 3: I turn on my laptop when it is connected to a network but my LDAP server is not available.  In this case, "id -ng" says, "id: cannot find group name for ID 500."  This is not good.

Additional info:

I can not figure out why scenario three fails.  Using the "-d" flag does not help, it just tells me that the group entries don't exist, not why:

4618: handle_request: request received (Version = 2) from PID 4626
4618:   GETFDGR
4618: provide access to FD 9, for group
4618: handle_request: request received (Version = 2) from PID 4626
4618:   GETGRBYGID (500)
4618: Haven't found "500" in group cache!
4618: add new entry "500" of type GETGRBYGID for group to cache (first)
4618: remove GETGRBYGID entry "500"

I have been told that pam_ccreds+nscd are appropriate tools for allowing laptops like mine to operate away from the network.

Comment 1 W. Michael Petullo 2005-06-27 14:55:44 UTC
This issue turned out to be due to a typo in /etc/nscd.conf.  Nscd seems to
behave properly now that the error was fixed.


Note You need to log in before you can comment on or make changes to this bug.