Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161748 - system-config-soundcard gives backtrace
Summary: system-config-soundcard gives backtrace
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: kudzu
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-26 23:19 UTC by Michal Jaegermann
Modified: 2014-03-17 02:54 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-02-03 17:08:46 UTC


Attachments (Terms of Use)
modprobe.conf after an upgrade (deleted)
2005-06-27 15:48 UTC, Michal Jaegermann
no flags Details
'lsmod' output (deleted)
2005-06-27 15:49 UTC, Michal Jaegermann
no flags Details
'aplay -l' output (deleted)
2005-06-27 15:51 UTC, Michal Jaegermann
no flags Details
a full copy of /etc/sysconfig/hwconf (deleted)
2005-06-27 15:53 UTC, Michal Jaegermann
no flags Details

Description Michal Jaegermann 2005-06-26 23:19:56 UTC
Description of problem:

An attempt to use a freshly installed system-config-soundcard from FC4
immediately ended like that

# system-config-soundcard
Traceback (most recent call last):
  File "/usr/share/system-config-soundcard/system-config-soundcard.py", line 46,
in ?
    app = soundcard.childWindow()
  File "/usr/share/system-config-soundcard/soundcard.py", line 64, in __init__
    self.cardList = self.soundcardBackend.probeCards()
  File "/usr/share/system-config-soundcard/soundcardBackend.py", line 143, in
probeCards
    self.defaultModule = self.cardList[0].driver
IndexError: list index out of range

The soundcard in question is actually "Trident Microsystems 4DWave DX"
and uses snd-trident.ko module.

Version-Release number of selected component (if applicable):
system-config-soundcard-1.2.12-2

How reproducible:
always

Comment 1 Martin Stransky 2005-06-27 09:50:40 UTC
Can you attach content of /etc/modprobe.conf, output of "lsmod",
output of "aplay -l", content of /proc/asound/modules and content of 
/etc/sysconfig/hwconf?

It look like missing/undetected sound card.

Comment 2 Michal Jaegermann 2005-06-27 15:48:36 UTC
Created attachment 116018 [details]
modprobe.conf after an upgrade

Attached is modprobe.conf after an update conversions - "as is".
With an exception of lines with /bin/aumix-minimal, which does not exist
anymore, what automatically happened looks sane.

In /proc/asound/modules there is only one line now.  Namely:

0 snd_trident

Here is a full look at a PCI bus on a machine in question:
-[0000:00]-+-00.0  VIA Technologies, Inc. VT8363/8365 [KT133/KM133]
	   +-01.0-[0000:01]--
	   +-04.0  VIA Technologies, Inc. VT82C686 [Apollo Super South]
	   +-04.1  VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C
PIPC Bus Master IDE
	   +-04.2  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
	   +-04.3  VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller
	   +-04.4  VIA Technologies, Inc. VT82C686 [Apollo Super ACPI]
	   +-09.0  Intel Corporation 82557/8/9 [Ethernet Pro 100]
	   +-0a.0  Trident Microsystems 4DWave DX
	   +-0c.0  ATI Technologies Inc Rage XL
	   \-11.0  Promise Technology, Inc. PDC20265 (FastTrak100
Lite/Ultra100)

and "AUDIO" portion of hwconf:

class: AUDIO
bus: PCI
detached: 0
driver: snd-trident
desc: "1023:2000"
vendorId: 1023
deviceId: 2000
subVendorId: 1023
subDeviceId: 2000
pciType: 1
pcidom:    0
pcibus:  0
pcidev:  a
pcifn:	0

The other files you ask for are attached further down.

This is not really a very exotic soundcard. :-)

Comment 3 Michal Jaegermann 2005-06-27 15:49:36 UTC
Created attachment 116020 [details]
'lsmod' output

Comment 4 Michal Jaegermann 2005-06-27 15:51:23 UTC
Created attachment 116021 [details]
'aplay -l' output

Comment 5 Michal Jaegermann 2005-06-27 15:53:10 UTC
Created attachment 116022 [details]
a full copy of /etc/sysconfig/hwconf

Comment 6 Martin Stransky 2005-06-28 11:45:38 UTC
Could you please check package here:

http://people.redhat.com/stransky/scs/

and send me output of it?

Comment 7 Michal Jaegermann 2005-06-28 14:30:07 UTC
system-config-soundcard-1.2.12-3.test did not give me a traceback this time
but it printed:

----------- CARD LIST ------------------
Desc:           Trident Microsystems 4DWave DX
Driver:         unknown
Device:         None

----------- CARD LIST END ------------------
---- self.cardlist -------
---- self.cardlist END -------

followed by an alert which basically said the same thing.

Mind you - this system is now for me "remote" and I will be not around
a local keyboard for some time.

Comment 8 Martin Stransky 2005-06-28 15:18:26 UTC
Thanks, it's what I've wanted. It looks like an undetected card by kudzu
(Driver: unknown and Device: None), but I don't know why, because you have the
right driver in hwconf but the description (Trident Microsystems 4DWave DX)
isn't here and kudzu returns right description without a driver.

Comment 9 Michal Jaegermann 2005-06-28 15:35:39 UTC
Mind you, kudzu seems to detect the card.  As I wrote before in hwconf we have

class: AUDIO
bus: PCI
detached: 0
driver: snd-trident

but look at 'desc:' tag.  It says "1023:2000" instead of "Trident Microsystems
4DWave DX".  This is actually correct but this alternate identifier is not
used.  Even if kudzu for some reasons is not coordinating these two an
identification by a PCI id should be good enough.



Comment 10 Martin Stransky 2005-06-29 07:40:14 UTC
Do you have a separate /usr? Maybe kudzu can't found pci.ids file...

Comment 11 Michal Jaegermann 2005-06-29 16:54:23 UTC
> Do you have a separate /usr?

Yes, indeed, I do.  Still when kudzu runs everything should be already
mounted as local file systems are mounted from rc.sysinit so this should
not matter.  Indeed it does not on FC3 installations and earlier with
/usr/share/hwdata/pci.ids not on a / partition.

OTOH if kudzu and/or other things rely on an "early" existence of this file
this is a severe bug regardless.  /usr/share is "share" also because it could
be mounted over, say, NFS and be common to the whole group of machines. In such
case this file will show up quite a bit later after a kudzu run.


Comment 12 Martin Stransky 2005-07-12 07:45:51 UTC
...backtrace is fixed in rawhide...

Comment 13 Martin Stransky 2006-02-03 08:42:02 UTC
Reassigning to kudzu...

Comment 14 Bill Nottingham 2006-02-03 17:08:46 UTC
Kudzu relies on pci.ids for descriptive strings, but those strings are not used
anywhere outside of UIs... and those UIs woulld all run with /usr mounted.
Considering the deprecated status of kudzu, this isn't really going to change.


Note You need to log in before you can comment on or make changes to this bug.