Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161742 - "choose font" dialog segfaults with Rawhide, works fine with FC4
Summary: "choose font" dialog segfaults with Rawhide, works fine with FC4
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-26 21:10 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-12 17:48:25 UTC


Attachments (Terms of Use)
full backtrace (deleted)
2005-06-26 21:10 UTC, Michael Schwendt
no flags Details

Description Michael Schwendt 2005-06-26 21:10:35 UTC
[Maybe is the wrong component.] Assuming this might be related to Cairo, since
the same applet works fine with FC4, where the same FreeType version is used.
Else the new GTK+ 2.7.0 or Pango. Full backtrace in separate attachment.

(gdb) bt
#0  0x005076db in memset () from /lib/libc.so.6
#1  0x00768927 in gray_raster_render () from /usr/lib/libfreetype.so.6
#2  0x00767481 in ps_hints_apply () from /usr/lib/libfreetype.so.6
#3  0x00768045 in gray_raster_render () from /usr/lib/libfreetype.so.6
#4  0x00735ca4 in FT_Outline_Render () from /usr/lib/libfreetype.so.6
#5  0x00735d65 in FT_Outline_Get_Bitmap () from /usr/lib/libfreetype.so.6
#6  0x009b9dac in _cairo_output_stream_create_for_file ()
   from /usr/lib/libcairo.so.1
#7  0x009ab86b in cairo_scaled_font_glyph_extents ()
   from /usr/lib/libcairo.so.1
#8  0x009aa1d8 in _cairo_arc_path_negative () from /usr/lib/libcairo.so.1
#9  0x009ba68a in cairo_ft_scaled_font_unlock_face ()
   from /usr/lib/libcairo.so.1
#10 0x009ab161 in cairo_scaled_font_create () from /usr/lib/libcairo.so.1
#11 0x009ab60d in cairo_scaled_font_glyph_extents ()
   from /usr/lib/libcairo.so.1
#12 0x0021ab70 in pango_cairo_fc_font_get_type ()
   from /usr/lib/libpangocairo-1.0.so.0
#13 0x00973335 in pango_font_get_glyph_extents ()
   from /usr/lib/libpango-1.0.so.0
#14 0x001e7dbc in ?? () from /usr/lib/pango/1.4.0/modules/pango-basic-fc.so
#15 0x001e801c in ?? () from /usr/lib/pango/1.4.0/modules/pango-basic-fc.so
#16 0x00979ff7 in _pango_engine_shape_shape () from /usr/lib/libpango-1.0.so.0
#17 0x00988d7d in pango_shape () from /usr/lib/libpango-1.0.so.0
#18 0x0097d61e in pango_layout_set_width () from /usr/lib/libpango-1.0.so.0
#19 0x0097fad2 in pango_layout_iter_get_char_extents ()
   from /usr/lib/libpango-1.0.so.0
#20 0x0098033a in pango_layout_iter_get_char_extents ()
   from /usr/lib/libpango-1.0.so.0
#21 0x009821ed in pango_layout_get_lines () from /usr/lib/libpango-1.0.so.0
#22 0x00b403e7 in gtk_entry_get_text () from /usr/lib/libgtk-x11-2.0.so.0
#23 0x00b4185b in gtk_entry_get_text () from /usr/lib/libgtk-x11-2.0.so.0
#24 0x008b9017 in g_cclosure_marshal_VOID__VOID ()
   from /usr/lib/libgobject-2.0.so.0
#25 0x008abf8b in g_cclosure_new_swap () from /usr/lib/libgobject-2.0.so.0
#26 0x008ac475 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#27 0x008bbdcb in g_signal_stop_emission () from /usr/lib/libgobject-2.0.so.0
#28 0x008bdbc8 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#29 0x008bdf19 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#30 0x00cb65e8 in gtk_widget_realize () from /usr/lib/libgtk-x11-2.0.so.0
-snip-


Version-Release number of selected component (if applicable):
cairo-0.5.1-3


How reproducible:
always

Steps to Reproduce:
1. build http://home.arcor.de/ms2002sep/tmp/gai-temp-0.1.0-1.src.rpm
   with build dependencies from Fedora Extras
2. add applet to panel (or start it)
3. open "Preferences" dialog, then "choose font" dialog


Actual results: segfault with FC Devel, no crash with FC4


Expected results: no crash

Comment 1 Michael Schwendt 2005-06-26 21:10:35 UTC
Created attachment 115992 [details]
full backtrace

Comment 2 Kristian Høgsberg 2005-06-26 22:19:15 UTC
Looks like another "missing bitmap fonts" crash.  Please try with cairo-0.5.1-4
once it's out.  Thanks.

Comment 3 Michael Schwendt 2005-06-28 12:39:00 UTC
Reproducible with cairo-0.5.1-4 and up-to-date Rawhide.

Comment 4 Michael Schwendt 2005-08-12 17:48:25 UTC
Tried once more (with cairo-0.6.0-2) and cannot reproduce any longer.


Note You need to log in before you can comment on or make changes to this bug.