Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161690 - ctrlproxy package still has perm issues
Summary: ctrlproxy package still has perm issues
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: ctrlproxy
Version: 4
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: David Woodhouse
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-25 22:16 UTC by Anduin Withers
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: 2.6.2-4
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-08 16:21:36 UTC


Attachments (Terms of Use)
spec patch to fix permissions (deleted)
2005-06-25 23:04 UTC, Michael Schwendt
no flags Details | Diff

Description Anduin Withers 2005-06-25 22:16:16 UTC
Description of problem:

No, this is not an irssi bug (sorry, no good component to pick).

ctrlproxy as currently packaged is useless (due to bad file perms mostly).


Version-Release number of selected component (if applicable):

Name        : ctrlproxy
Version     : 2.6.2
Release     : 2.fc4


How reproducible:


(Just to pick one, there are several others)

Steps to Reproduce:
1. Install ctrlproxy
2. Attempt to use it
3. Fail

4. ls -ld /usr/lib/ctrlproxy

drw-r--r--  2 root root 4096 Jun 25 17:37 /usr/lib/ctrlproxy/
  
Actual results:

Many file permissions are wrong (to the point of non-root users not being able 
to get to doc directory, or load the module in /usr/lib/ctrlproxy).

Basically someone should try to use it as a non-root user, it fails quickly.

(It is also missing modules (like stats) that it installs man pages for (and 
the default config tool/config file uses))


Expected results:

1. Install
2. Works

Additional info:

Comment 1 Michael Schwendt 2005-06-25 23:03:12 UTC
Next time pick "general" instead of a completely unrelated component.

I requested component creation for ctrlproxy here:
http://fedoraproject.org/wiki/Extras/BugzillaAdmin


Comment 2 Michael Schwendt 2005-06-25 23:04:42 UTC
Created attachment 115982 [details]
spec patch to fix permissions

FE CVS shows an attempt at fixing the file permissions. Here's a patch to fix
them completely.

Comment 3 Anduin Withers 2005-06-25 23:37:16 UTC
(In reply to comment #1)

> Next time pick "general" instead of a completely unrelated component.

Didn't know "general" existed, I did bother to put a relevant e-mail address 
in. Thanks for the tip.


Comment 4 Josh Boyer 2005-08-06 02:35:37 UTC
Ok, I've applied this patch in CVS and pushed new packages to the build system.
 David will yell at me later if he wants to, but I doubt he will :)


Note You need to log in before you can comment on or make changes to this bug.