Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161689 - Packaging bug (seems %{buildroot} is hardcoded in paths)
Summary: Packaging bug (seems %{buildroot} is hardcoded in paths)
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: pygtk2
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-25 20:53 UTC by Patrick
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version: pygtk2-2.10.3-2.fc6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-10-30 02:12:53 UTC


Attachments (Terms of Use)
patch for pygtk2-2.6.0-2 (deleted)
2005-06-25 22:33 UTC, Michael Schwendt
no flags Details | Diff
spec changes (deleted)
2005-06-25 22:34 UTC, Michael Schwendt
no flags Details | Diff

Description Patrick 2005-06-25 20:53:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When starting a python app like yumex I get the following error:
[root@srv12 ~]# yumex
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
  File "yumex.py", line 23, in ?
  File "yumWrapper.py", line 26, in ?
  File
"/usr/src/build/535819-i386/install/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?
RuntimeError: could not open display

Looks like pygtk2 was built with the %{buildroot} prepended in hardcoded
paths. pygtk2 version is 2.6.0-2 on FC4. The Xlib error is solved with Alexander Dalloz's suggestion to do xhost +local:root before starting yumex. 

Version-Release number of selected component (if applicable):
pygtk2-2.6.0-2

How reproducible:
Always

Steps to Reproduce:
1. start yumex
2. read error message/traceback
3. 
  

Actual Results:  Traceback (most recent call last):
  File "yumex.py", line 23, in ?
  File "yumWrapper.py", line 26, in ?
  File
"/usr/src/build/535819-i386/install/usr/lib/python2.4/site-packages/gtk-2.0/gtk/__init__.py", line 37, in ?


Expected Results:  no traceback, yumex starts properly

Additional info:

Comment 1 Michael Schwendt 2005-06-25 22:33:36 UTC
Created attachment 115980 [details]
patch for pygtk2-2.6.0-2

The buildroot in the compiled Python files has nothing to do with your display
problem.

But the fix is attached. Upstream ought to update py-compile and use --destdir
appropriately.

Comment 2 Michael Schwendt 2005-06-25 22:34:09 UTC
Created attachment 115981 [details]
spec changes

Comment 3 Matthew Barnes 2006-10-30 02:12:53 UTC
I was able to start yumex successfully with the current pygtk2 release (2.10.3),
so I'm closing this bug.  Please feel free to reopen it if you still encounter
the reported problem.


Note You need to log in before you can comment on or make changes to this bug.