Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161688 - cairo-devel package is missing dependencies and breaks other src.rpms
Summary: cairo-devel package is missing dependencies and breaks other src.rpms
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-25 19:51 UTC by Michael Schwendt
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-26 19:54:45 UTC


Attachments (Terms of Use)

Description Michael Schwendt 2005-06-25 19:51:39 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
cairo-devel is missing:

  Requires: libpng-devel xorg-x11-devel

[...]

Why? Because these are its dependencies in the cairo.pc pkg-config template. Please fix this as it breaks other packages, e.g. in Extras, where cairo-devel is an indirect build requirement.

[...]

checking for libgnome-2.0 >= 2.0.0
                  libgnomeui-2.0 >= 2.0.0
                  gtk+-2.0 >= 2.4.0
                  gnome-vfs-2.0 >= 2.6.0
                  libglade-2.0 >= 2.3.6... Package libpng12 was not found in the
 pkg-config search path.
Perhaps you should add the directory containing `libpng12.pc'
to the PKG_CONFIG_PATH environment variable
Package 'libpng12', required by 'cairo', not found


Version-Release number of selected component (if applicable):
cairo-devel-0.5.1-3

How reproducible:
Always

Steps to Reproduce:
-


Additional info:

Comment 1 Michael Schwendt 2005-06-26 13:39:13 UTC
gtk2-devel's pkg-config support is also broken by this.

Comment 2 Kristian Høgsberg 2005-06-26 19:54:45 UTC
Thanks, this should be fixed in rawhide now.



Note You need to log in before you can comment on or make changes to this bug.