Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161655 - console usable after exiting X
Summary: console usable after exiting X
Keywords:
Status: CLOSED DUPLICATE of bug 161242
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 23:12 UTC by Matthew Galgoci
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-30 08:28:32 UTC


Attachments (Terms of Use)
X log (deleted)
2005-06-24 23:12 UTC, Matthew Galgoci
no flags Details
X log (deleted)
2005-06-30 00:37 UTC, Mike Perry
no flags Details
X log (deleted)
2005-07-02 14:15 UTC, Hervé Riboulot
no flags Details

Description Matthew Galgoci 2005-06-24 23:12:51 UTC
Description of problem:

On stock fedora core 4, I can start X, but if I exit, I get a blank screen. I
can easily type startx again, and X starts up with no problem.

Version-Release number of selected component (if applicable):

Kernels 2.6.11-1.1369_FC4 and stock 2.6.12 tested
xorg-x11-6.8.2-37

X loads the i915 drm driver and the i810 x11 driver.

dmesg shows this:

[drm] Initialized drm 1.0.0 20040925
ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 3 (level, low) -> IRQ 3
[drm] Initialized i915 1.1.0 20040405 on minor 0:
[drm] Initialized i915 1.1.0 20040405 on minor 1:
mtrr: base(0xe0000000) is not aligned on a size(0x300000) boundary
audit(:343108): major=252 name_count=0: freeing multiple contexts (1)
audit(:329240): major=113 name_count=0: freeing multiple contexts (2)
mtrr: base(0xe0000000) is not aligned on a size(0x300000) boundary

lspci shows this for my hardware:

00:02.0 VGA compatible controller: Intel Corporation 82830 CGC [Chipset Graphics
Controller] (rev 04)00:02.1 Display controller: Intel Corporation 82830 CGC
[Chipset Graphics Controller]


How reproducible:

100%

Steps to Reproduce:
1. startx
2. exit x
  
Actual results:

Console is blank, however keyboard input is attached and the kernel is taking
input. I can type startx and get back to an X session with no otherwise ill 
effect.

Expected results:

A text console that I can see and is usable.

Additional info:

See attached X log.

Comment 1 Matthew Galgoci 2005-06-24 23:12:51 UTC
Created attachment 115962 [details]
X log

Comment 2 Mike Perry 2005-06-30 00:35:29 UTC
I would like to add this happens with my Intel 82852/855GM. I also experience an
inability to switch to virtual consoles while X is still running.

I get a similar message in dmesg:

[drm] Initialized drm 1.0.0 20040925
ACPI: PCI Interrupt 0000:00:02.0[A] -> Link [LNKA] -> GSI 10 (level, low) -> IRQ 10
[drm] Initialized i915 1.1.0 20040405 on minor 0: 
[drm] Initialized i915 1.1.0 20040405 on minor 1: 
mtrr: base(0xe8020000) is not aligned on a size(0x300000) boundary
    ACPI-0304: *** Error: Looking up [PBST] in namespace, AE_ALREADY_EXISTS
    ACPI-1172: *** Error: Method execution failed [\_SB_.PCI0.LPCB.BAT1._BST]
(Node edda8320), AE_ALREADY_EXISTS

xorg-x11-6.8.2-37

Comment 3 Mike Perry 2005-06-30 00:37:45 UTC
Created attachment 116157 [details]
X log

Comment 4 Mark Komarinski 2005-06-30 13:28:48 UTC
I can't switch to a VC from X, and can't get a VC up if I go to runlevel 3.
Intel 82852/855GM (IBM X40 laptop).

At first I thought this might be a artifact of doing a yum upgrade, but I guess not.

Comment 5 Hervé Riboulot 2005-07-02 14:15:15 UTC
Created attachment 116291 [details]
X log

Comment 6 Hervé Riboulot 2005-07-03 10:14:56 UTC
Same trouble for another chipset:

01:00.0 VGA compatible controller: S3 Inc. ProSavage KM133 (rev 03)

Comment 7 Matthew Galgoci 2005-07-04 19:57:13 UTC
I worked around this problem.

I read the man page for the i810 driver and found a boolean option that helped.

Setting this option in the Device section makes the problem go away:

Option "VBERestore" "yes"

I'm not sure why this is necessary now.

Comment 8 Mike A. Harris 2005-07-05 10:11:22 UTC
This may or may not be a duplicate of bug #161242, which appears as a wide
variety of symptoms.  Test the workaround present in bug #161242 to determine
if this is a duplicate of that issue, or a separate one.

TIA

Comment 9 Mike Perry 2005-07-08 22:45:48 UTC
The libvgahw workaround from bug #161242 fixes the issue for me.

Comment 10 Mike A. Harris 2005-07-12 10:30:35 UTC
(In reply to comment #9)
> The libvgahw workaround from bug #161242 fixes the issue for me.

Thanks for the update Mike.  I'll leave this open for a while to give
Matt a chance to test the workaround also, just in case his issue
is a different one.  I believe there are other remaining issues in
the i810 driver.

Matt, does the bug #161242 workaround make the problem go away?

Comment 11 Mike A. Harris 2005-08-30 08:28:32 UTC

*** This bug has been marked as a duplicate of 161242 ***


Note You need to log in before you can comment on or make changes to this bug.