Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161653 - crash when viewing python documentation
Summary: crash when viewing python documentation
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: cairo
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 22:11 UTC by Colin Walters
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-26 19:53:27 UTC


Attachments (Terms of Use)
valgrind log (deleted)
2005-06-24 22:12 UTC, Colin Walters
no flags Details

Description Colin Walters 2005-06-24 22:11:19 UTC
Description of problem:

Browse to /usr/share/doc/python-docs-2.4.1/html/lib/index.html

Firefox crashes.


Version-Release number of selected component (if applicable):
firefox-1.0.4-5

How reproducible:
Every time

Steps to Reproduce:
1. /usr/share/doc/python-docs-2.4.1/html/lib/index.html

Will attach a partial stack trace from valgrind.

Comment 1 Colin Walters 2005-06-24 22:12:22 UTC
Created attachment 115961 [details]
valgrind log

Comment 2 Colin Walters 2005-06-25 20:21:06 UTC
Reassigning to cairo per this discussion.

Jun 24 18:15:36 owen	at 0x3BC391FF: ??? (nsFontMetricsPango.cpp:341) is
probbably good enough. Maybe krh wants to compare it to his patch
Jun 24 18:16:17 *	krh looks at line 341
Jun 24 18:16:26 clarkbw	it was "lucida typewriter" that was the problem
Jun 24 18:16:34 clarkbw	if this is the same thing...
Jun 24 18:17:14 owen	clarkbw: May be fixed in cairo CVS ...  Ijust made bitmap
fonts work with cairo and pango
Jun 24 18:21:46 krh	owen: this is division by zero because
face->size->metrics.ascender - face->size->metrics.descender is 0
Jun 24 18:22:49 owen	krh: Yep, that will be the case with bitmap fonts with 0.5.1


Comment 3 Kristian Høgsberg 2005-06-26 19:53:27 UTC
Fixed in rawhide. Why is the python documentation hardcoding butt-ugly bitmap
fonts anyway?


Note You need to log in before you can comment on or make changes to this bug.