Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161627 - tar options --exclude and --exlude-from no more work
Summary: tar options --exclude and --exlude-from no more work
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: tar
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Peter Vrabec
QA Contact: Ben Levenson
URL:
Whiteboard:
: 162173 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 21:33 UTC by Marco Ferragina
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-28 09:57:07 UTC


Attachments (Terms of Use)

Description Marco Ferragina 2005-06-24 21:33:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; it-IT; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Good: options --exlude and --exlude-from simply no more work.
When I try to make a tar archive with one of this options, files listed after --exlude option are not exluded from archive how it does in fedora core 3

Version-Release number of selected component (if applicable):
tar-1.15.1-5

How reproducible:
Always

Steps to Reproduce:
1. create two files: Example test blah
2. create tar archive: tar -cjf test.tar.bz2 * --exclude=blah
3. Cannot stat: No such file or directory
  

Additional info:

Comment 1 Joe Bayes 2005-06-25 15:59:53 UTC
Try creating your archive with "tar cjf test.tar.bz2 --exclude=blah *" 
That WFM, tar-1.15.1-5

Comment 2 Marco Ferragina 2005-06-26 08:35:07 UTC
Thanks, it also works with tar --exclude=blah -cjf test.tar.bz2 *
It's not a bug ;) simply a new syntax from previous version

Comment 3 Peter Vrabec 2005-07-01 07:36:30 UTC
*** Bug 162173 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.