Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161624 - As built, gd requires glibc > 2.3.3
Summary: As built, gd requires glibc > 2.3.3
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gd
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 21:21 UTC by Jeff Spirko
Modified: 2015-03-05 01:14 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-27 09:39:41 UTC


Attachments (Terms of Use)

Description Jeff Spirko 2005-06-24 21:21:05 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050414 Firefox/1.0.3

Description of problem:
With glibc 2.3.3, programs using this version of the gd library will not link because of a missing __sprintf_chk, etc. symbols.  These symbols are present in glibc 2.3.5.  This affects people who try to upgrade to this version of gd while not doing a full upgrade of their system to fc4.


Version-Release number of selected component (if applicable):
gd-2.0.33

How reproducible:
Always

Steps to Reproduce:
1. Downgrade to glibc-2.3.3
2. Create a simple test program that uses gd, called gdtst.c:
char gdImageCreate ();
int main () {
  gdImageCreate ();
  return 0;
}
3. Compile the program (edit for location of libX11.so):
  gcc -L[location of libX11.so] -o gdtst gdtst.c -lgd -lXpm -lX11
  

Actual Results:  gcc failed to produce the executable.

Additional info:

This version of the gd library appears to work with X11R6; i.e. it may not require xorg, even though it is labeled as such.

Comment 1 Phil Knirsch 2005-06-27 09:39:41 UTC
Such partial updates can often lead to such problems and it's not a gd specific
problem.

Unfortunately there are only 3 possible ways out of this:

1) Update gd with yum and pull in all required dependant updates as well
2) Don't update gd
3) Rebuild the FC4 srpm on the FC3 system and install that.

Read ya, Phil

Comment 2 Jeff Spirko 2005-06-27 18:49:33 UTC
I was doing (1).  My point was that gd-2.0.33-2 isn't marked as requiring an
update of glibc from 2.3.3 to 2.3.5, though it should be.

After manually updating to glibc-2.3.5-10, gd now works fine.



Note You need to log in before you can comment on or make changes to this bug.