Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161582 - rpm is unable to install files placed in paths with spaces in the name
Summary: rpm is unable to install files placed in paths with spaces in the name
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: rpm
Version: rawhide
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Paul Nasrat
QA Contact: Mike McLean
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 17:06 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-11-28 19:31:10 UTC


Attachments (Terms of Use)

Description David Nielsen 2005-06-24 17:06:53 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050513 Epiphany/1.7.1

Description of problem:
By default rpm doesn't correctly parse paths with spaces in them, now for normal use this isn't a big issue, one could just avoid names with spaces. However I'm on Danish locale and my default Downloads dir is called "Hentede filer", which I presume is the default (it was when I created it at least) for this locale. This means that every time a user clicks an rpm file it will go there and since system-package-config (or whatever handles package install graphically) uses rpm underlying it will fail. 

LANG=C rpm -Uvh "Hentede\ filer/skype-1.1.0.13-fc3.i586.rpm" will work, but that is not how rpm reads that dir name by default, thus causing the problem for the frontend that the user would see.

Version-Release number of selected component (if applicable):
rpm-4.4.1-21

How reproducible:
Always

Steps to Reproduce:
1. install .rpm file placed in a dir with spaces in the name

  

Actual Results:  LANG=C rpm -Uvh Hentede\ filer/skype-1.1.0.13-fc3.i586.rpm
error: open of Hentede failed: No such file or directory
error: open of filer/skype-1.1.0.13-fc3.i586.rpm failed: No such file or directory


Expected Results:  correct install

Additional info:

Comment 1 Paul Nasrat 2005-11-28 19:31:10 UTC
Double quoting is needed to support globs in rpm itself (once for shell, once
for rpm).

Comment 2 David Nielsen 2005-11-28 19:48:33 UTC
Still, this breaks the system-package-config frontend for EVERYBODY that places
rpms default in a spaced path - like danish users would.

I consider this quite critical as it completely by default breaks on every
machine around me. Something needs to be done.

Comment 3 Paul Nasrat 2005-11-28 22:59:52 UTC
System-config-packages in it's current form is going away, and doesn't exec rpm
directly.  We'll try to ensure that the replacement for s-c-p works, but that's
a seperate issue from this.


Note You need to log in before you can comment on or make changes to this bug.