Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161576 - Division by zero in nsFontMetricsPango::CacheFontMetrics
Summary: Division by zero in nsFontMetricsPango::CacheFontMetrics
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: rawhide
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL: http://docs.python.org/ref/yield.html
Whiteboard:
: 162406 (view as bug list)
Depends On:
Blocks: FIREFOX_PANGO
TreeView+ depends on / blocked
 
Reported: 2005-06-24 15:45 UTC by Robin Green
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-04-01 14:53:49 UTC


Attachments (Terms of Use)
Backtrace from gdb (deleted)
2005-06-24 15:45 UTC, Robin Green
no flags Details

Description Robin Green 2005-06-24 15:45:28 UTC
Description of problem:   
Firefox crashes with SIGFPE when visiting 
http://docs.python.org/ref/yield.html , caused by attempt to divide by zero, 
when latest  
gtk2/pango/cairo is installed from rawhide. The zero   
value is in the lineHeight variable in nsFontMetricsPango::CacheFontMetrics. 
Backtrace attached.   
   
Version-Release number of selected component (if applicable):   
firefox-1.0.4-5  
   
How reproducible:   
Always 
   
Steps to Reproduce:   
1. firefox 'http://docs.python.org/ref/yield.html' 
     
Actual results:   
<snip> 
/usr/lib/firefox-1.0.4/run-mozilla.sh: line 159: 14390 Floating point 
exception"$prog" ${1+"$@"} 
   
Expected results:   
No crash 
   
Additional info: 
All latest updates from rawhide installed. 
Workaround: Run firefox with 
MOZ_DISABLE_PANGO=1 firefox

Comment 1 Robin Green 2005-06-24 15:45:28 UTC
Created attachment 115938 [details]
Backtrace from gdb

Comment 2 Daniel Malmgren 2005-07-20 09:58:16 UTC
*** Bug 162406 has been marked as a duplicate of this bug. ***

Comment 3 Matthias Clasen 2007-04-01 14:53:49 UTC
I am pretty sure that this is fixed by now; we are running pango-enabled firefox
by default for a while now, and the cited web page loads fine for me. 

Please reopen if you still see this problem.


Note You need to log in before you can comment on or make changes to this bug.