Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161563 - no dhcpd runnnig
Summary: no dhcpd runnnig
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: dhcp
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jason Vas Dias
QA Contact:
URL: ?
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 14:20 UTC by f.j.smans
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-05 14:29:32 UTC


Attachments (Terms of Use)

Description f.j.smans 2005-06-24 14:20:35 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)

Description of problem:
When i start the DHCPD the following erroe message occurs on the screen:

no subnet declaration for start (0.0.0.0)
not configured to listen to any interface.

in mine hdchd.conf there is a subnet declarition

Version-Release number of selected component (if applicable):
fc4 core

How reproducible:
Always

Steps to Reproduce:
1. dhcpd start
2.
3.
  

Actual Results:  above msg

Expected Results:  dhcpd should start

Additional info:

Comment 1 f.j.smans 2005-07-03 14:18:42 UTC
part of my dhcpd.conf

subnet 193.100.10.0 netmask 255.255.255.0 {
  option domain-name-servers 193.100.10.1;
  option routers 193.100.10.1;
}


Comment 2 Jason Vas Dias 2005-07-05 14:29:32 UTC
 The problem is the command you used to start dhcpd : 
 # dhcpd start
 would make dhcpd look for an interface named "start", which
 would be the only interface it would be configured to serve, 
 and which probably does not exist on your system.
 You probably meant to do:
 # service dhcpd start
 or
 # /etc/init.d/dhcpd start
 Which would use the dhcpd initscript to start dhcpd to serve any
 interface on subnet 
 193.100.10.0/24 .
 If multiple interfaces are on this subnet, you could put the
 interface name you want dhcpd to serve in /etc/sysconfig/dhcpd -
 ie. if the only interface you want dhcpd to serve is named "eth0",
 putting this line in /etc/sysconfig/dhcpd will make dhcpd only
 serve eth0:
 "
 DHCPDARGS=eth0
 ".


Note You need to log in before you can comment on or make changes to this bug.