Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161535 - menu delay in GNOME panel
Summary: menu delay in GNOME panel
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-panel
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mark McLoughlin
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-24 01:21 UTC by Teddy
Modified: 2007-11-30 22:11 UTC (History)
3 users (show)

Fixed In Version: gnome-panel-2.11.4-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-08-04 07:12:40 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
GNOME Bugzilla 164574 None None None Never

Description Teddy 2005-06-24 01:21:56 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
When clicking on the menu items in the GNOME panel (for example Applications, PLaces, Desktop) there is sometimes a several second delay before it opens.  It apparently happens randomly... whether I have any windows open or not.

Version-Release number of selected component (if applicable):
gnome-menus-2.10.1-3

How reproducible:
Sometimes

Steps to Reproduce:
Not sure how to reproduce... happens randomly (apparently)
  

Additional info:

Comment 1 Teddy 2005-06-24 01:35:29 UTC
Additional Info:
USB Logitech Optical Scroll Mouse

Comment 2 Mark Knoop 2005-06-30 16:21:24 UTC
Not sure if this is the same bug or not, but I get a significant delay only the
first time after logging in or installing a new package. It seems that the menu
is being rebuilt, but not until requested. 

Also see this thread: http://forums.fedoraforum.org/showthread.php?p=296233

Comment 3 William Lovaton 2005-08-03 03:35:37 UTC
I think this is something related to GTK+ and it happens only the first time
after log in, it is fast again after that.  But the delay is huge and annoying,
about 3-5 seconds.  I know for sure that the whole time is spent reading a lot
from the hard disk.  The funny thing is that I have Ubuntu Hoary (Gnome 2.10)
installed on another (slower) machine and it is always fast, even the first time
so this is specific to Fedora Core 4 (Fedora Core 3 is fast too).

I'll try to strace the panel or what ever process it is and attach the result to
this bug report.

mclasen, are you aware of this issue?  I was tempted to write directly to you
until I found this bug report.

Regards,

-William


Comment 4 Ray Strode [halfline] 2005-08-03 05:22:39 UTC
Well, my first unresearched guess at why this would be slow would be icon loading.

Note gtk+ has gained icon image caching since FC3, so it may be a bug in that. 

Not really sure...assigning to gnome-panel for now.

Comment 5 Mark McLoughlin 2005-08-04 07:12:40 UTC
No, this delay had to do with the loading of the .desktop files themselves.

The panel in rawhide loads the menus in an idle handler now, so you shouldn't
see this delay. See:

  http://bugzilla.gnome.org/show_bug.cgi?id=164574

Comment 6 William Lovaton 2005-08-05 14:46:44 UTC
Mark, does this mean that FC4 wont get any fix? any plan to backport the code
from the devel branch?  as I said, Ubuntu Hoary is performing ok in this regard.


Note You need to log in before you can comment on or make changes to this bug.