Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1615348 - [RFE] Update playbook to deploy oVirt metrics store using Origin on oVirt role
Summary: [RFE] Update playbook to deploy oVirt metrics store using Origin on oVirt role
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: RFEs
Version: unspecified
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ovirt-4.3.3
: 1.2.1.3
Assignee: Shirly Radco
QA Contact: Ivana Saranova
URL:
Whiteboard:
: 1599589 1647462 (view as bug list)
Depends On:
Blocks: 1645105 1693682 1507407 1598423 1646154
TreeView+ depends on / blocked
 
Reported: 2018-08-13 11:58 UTC by Shirly Radco
Modified: 2019-04-16 13:58 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
In this release, an Ansible playbook enables you to deploy the Metrics Store on a single node or on multiple nodes and to scale out an existing deployment.
Clone Of:
Environment:
Last Closed: 2019-04-16 13:58:14 UTC
oVirt Team: Metrics
apinnick: needinfo-
rule-engine: ovirt-4.3+
lsvaty: testing_plan_complete?
ylavi: planning_ack+
sradco: devel_ack+
lsvaty: testing_ack+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 93341 master ABANDONED ansible: automate metrics store installation 2018-11-22 11:55:31 UTC

Description Shirly Radco 2018-08-13 11:58:14 UTC
Description of problem:
Add a playbook that will install oVirt metrics store as an all-in-one or with multiple nodes and also scale out an existing installation.

Comment 1 Lukas Svaty 2018-08-14 08:23:29 UTC
Hi Shirly,

can you share a bit more information about this? For QA Ack we need requirements specification, to ensure we have all that is needed.

Verification steps/feature page would be great as well.

Thanks,
LS

Comment 2 Shirly Radco 2018-08-14 10:35:01 UTC
Sure,

1. The user needs to update in the /etc/ovirt-engine-metrics/config.yml the node he wants to deploy elasticsearch on, based on the example file /etc/ovirt-engine-metrics/config.yml.example.

2. There should be one master node and additional nodes in the fluentd_elasticsearch_nodes parameter. In our use case the master nodes and additional nodes are vms in oVirt.

3. The nodes hardware requirements are stated here https://docs.okd.io/latest/architecture/infrastructure_components/kubernetes_infrastructure.html#node

4. In order to run the playbook run:
/usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh -vvv --playbook=ovirt-metrics-store-installation.yml

5. The playbook will automatically either :
  5.1. Install OpenShift logging all-in-one on a single node if only fluentd_elasticsearch_host is configured
  5.2.  Install OpenShift logging on several nodes
  5.3.  Add additional nodes

6. The playbook runs the openshift-ansible playbooks from the engine machine. This is a change from the way we run them before (From the master node itself).

7. In the beginning of the playbook it creates passwordless connection to the nodes, the user will be prompt for password and the engine public key will be automatically copied to the nodes.

8. The parameters that set  the OpenShift version and distribution are:
openshift_version: 3.9
openshift_distribution: origin
They can be updated in the /etc/ovirt-engine-metrics/config.yml file or by adding a new vars file to the /etc/ovirt-engine-metrics/config.yml.d/ directory.

In d/s the the rpm package includes a vars file called "00-rhvm-defaults.yml" that is added to /etc/ovirt-engine-metrics/config.yml.d/ and sets openshift_distribution: ocp


**Note: I encountered one time an ssh connection timeout after the openshift-ansible playbooks finished , but rerunning the ovirt-metrics-store-installation.yml playbook ( /usr/share/ovirt-engine-metrics/configure_ovirt_machines_for_metrics.sh -vvv --playbook=ovirt-metrics-store-installation.yml)  fixed the issue.

**Note: The playbook does not upgrade OpenShift.

Comment 3 Shirly Radco 2018-08-14 11:00:47 UTC
The link for the nodes hardware requirments is incorrect in #comment2.
This is the correct link :https://docs.okd.io/3.10/install/prerequisites.html

Comment 5 Shirly Radco 2018-10-28 08:35:40 UTC
Since there is already work on having a generic OKD/OCP on oVirt/RHV, This bug will be based on it and only add the relevant oVirt metrics parameters and additional relevant tasks.

Comment 6 Shirly Radco 2018-11-18 10:58:55 UTC
*** Bug 1647462 has been marked as a duplicate of this bug. ***

Comment 7 Sandro Bonazzola 2019-01-28 09:39:54 UTC
This bug has not been marked as blocker for oVirt 4.3.0.
Since we are releasing it tomorrow, January 29th, this bug has been re-targeted to 4.3.1.

Comment 9 Shirly Radco 2019-02-25 12:49:41 UTC
*** Bug 1599589 has been marked as a duplicate of this bug. ***

Comment 10 Sandro Bonazzola 2019-03-12 12:54:20 UTC
4.3.1 has been released, please re-target this bug as soon as possible.

Comment 11 Ivana Saranova 2019-04-04 14:18:28 UTC
Since the metrics installation changed quite a bit from the initial expectations, I tested it with the current official documentation.

Steps:
1) Install metrics store according to this documentation: https://access.redhat.com/documentation/en-us/red_hat_virtualization/4.3-beta/html/metrics_store_installation_guide/index

Result:
Installation was successful, the metrics store is created and working, all pods, services and routes are running and ready.

Verified in: 
ovirt-engine-4.2.8.5-0.1.el7ev.noarch
ovirt-engine-metrics-1.2.1.3-1.el7ev.noarch

Also verified in:
ovirt-engine-4.3.3.1-0.1.el7.noarch
ovirt-engine-metrics-1.2.1.3-1.el7ev.noarch

If you think this is not enough for the verification, feel free to reopen the bug.

Comment 12 Sandro Bonazzola 2019-04-16 13:58:14 UTC
This bugzilla is included in oVirt 4.3.3 release, published on April 16th 2019.

Since the problem described in this bug report should be
resolved in oVirt 4.3.3 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.