Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161530 - OpenOffice does not include Northern Sotho (nso) or Tswana (tn) language packs
Summary: OpenOffice does not include Northern Sotho (nso) or Tswana (tn) language packs
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: openoffice.org
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 23:33 UTC by Dwayne Bailey
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version: 2.0.2-5.9.3
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-04-14 15:53:10 UTC


Attachments (Terms of Use)

Description Dwayne Bailey 2005-06-23 23:33:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
Both Northern Sotho (nso_ZA) and Tswana (tn_ZA) were included in OOo 1.1.3 and should be in the new versions.

Note nso in the real locale name but OOo has used ns in their builds which may cause some confusion

Version-Release number of selected component (if applicable):
openoffice.org-core-1:1.9.104-2

How reproducible:
Always

Steps to Reproduce:

  

Additional info:

Comment 1 Caolan McNamara 2005-07-04 08:07:02 UTC
caolanm->notting: what do you think ? The thing is that I think the rest of
fedora doesn't support these locales ?

Comment 2 Dwayne Bailey 2005-07-04 09:23:56 UTC
Nothern Sotho was translated as part of the installer so I guess it should be there:

This is the bug against glibc for the locales:
Northern Sotho: http://sources.redhat.com/bugzilla/show_bug.cgi?id=486
Tswana: http://sources.redhat.com/bugzilla/show_bug.cgi?id=529

This is the bug against X.org to include them and other South African locales there:
https://bugs.freedesktop.org/show_bug.cgi?id=2268

If you could get these patched and maybe other South African languages I would
really appreciate it as I'm not sure how to get any of this committed as nobody
responds.

Comment 3 Bill Nottingham 2005-07-05 00:54:13 UTC
At this point, it's probably best to wait on glibc before adding the OpenOffice
bits.

Comment 4 Dwayne Bailey 2005-07-08 13:03:57 UTC
I think that is my frustration we've been waiting on glibc since Oct 2004 and X
since Jan 2005.  At this rate we'll be waiting forever.

Comment 5 Caolan McNamara 2005-07-08 13:17:19 UTC
caolanm->jakub: know anything about glibc support for these south african locales ?

Comment 6 Caolan McNamara 2006-04-12 12:36:40 UTC
glibc now supports these locales

Comment 7 Caolan McNamara 2006-04-12 14:14:07 UTC
Will give a whirl at building them for rawhide now that glibc supports them


Note You need to log in before you can comment on or make changes to this bug.