Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161520 - gfortran internal compiler error: convert_move expr.c
Summary: gfortran internal compiler error: convert_move expr.c
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gcc
Version: 4
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 21:58 UTC by Patrice Dumas
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-07-07 15:48:02 UTC


Attachments (Terms of Use)

Description Patrice Dumas 2005-06-23 21:58:38 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.7.2) Gecko/20040804

Description of problem:
Trying to compile:

      SUBROUTINE HWBRAN()
      DOUBLE PRECISION HWBVMC,QGTHR
      EXTERNAL HWBVMC
      CALL HWWARN(*999)
      QGTHR=MAX(1D00,HWBVMC(59)*EXP(0.75))
  999 END


I get
[dumas@couperin code]$ gfortran -c -o hwbran hwbran.f
hwbran.f: In function 'hwbran':
hwbran.f:5: internal compiler error: in convert_move, at expr.c:339





Version-Release number of selected component (if applicable):
gcc-gfortran-4.0.0-8

How reproducible:
Always

Steps to Reproduce:
1.lanch the above command on the above code
2.
3.
  

Actual Results:  an internal compiler error

Expected Results:  A compilation

Additional info:

Comment 1 Patrice Dumas 2005-06-24 06:30:00 UTC
This seems to be fixed in rawhide gcc-gfortran-4.0.0-12

Comment 2 Jakub Jelinek 2005-07-07 15:48:02 UTC
A new FC4 gcc will be eventually released and will be based on whatever is
ATM on gcc-4_0-rhl-branch (which 4.0.0-12 is built from).


Note You need to log in before you can comment on or make changes to this bug.