Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161518 - cvs repository exploring perspective throws exception browsing cvs.gnome.org
Summary: cvs repository exploring perspective throws exception browsing cvs.gnome.org
Keywords:
Status: CLOSED INSUFFICIENT_DATA
Alias: None
Product: Fedora
Classification: Fedora
Component: eclipse
Version: 4
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 21:49 UTC by Colin Walters
Modified: 2007-11-30 22:11 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2006-05-05 20:42:05 UTC


Attachments (Terms of Use)
eclipse log (deleted)
2005-06-23 21:50 UTC, Colin Walters
no flags Details
Eclipse log (deleted)
2005-11-12 14:10 UTC, Axon
no flags Details

Description Colin Walters 2005-06-23 21:49:22 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
This is a fresh install of FC4 and Eclipse, no workspace or anything.  I used the CVS Repository Exploring perspective, and added a new repository: anoncvs.gnome.org/pserver/anonymous , then clicked on "HEAD".  Eclipse showed about a fifth perhaps of the list, then threw an exception, and failed to show the remainder.  I'll attach the output from ~/workspace/.metadata/.log


Version-Release number of selected component (if applicable):
eclipse-platform-3.1.0_fc-0.M6.22

How reproducible:
Always

Steps to Reproduce:
1. Start Eclipse
2. Add new repostory with host: anoncvs.gnome.org  method: pserver  username: anonymous
3. Click HEAD
  

Additional info:

Comment 1 Colin Walters 2005-06-23 21:50:17 UTC
Created attachment 115905 [details]
eclipse log

Comment 2 Andrew Overholt 2005-06-24 20:15:45 UTC
I've never seen this type of behaviour.  Before I tell you to upgrade to what's
in rawhide (or wait for 3.1 final next week - I'll be doing an FC4 update then),
try rm -rf ~/.eclipse and try again.  There always seem to be problems with
~/.eclipse when moving between versions and/or JVMs.

Comment 3 Axon 2005-09-04 14:44:42 UTC
I'm getting exactly the same error with 3.1.0_fc-0.M6.22. Even when I 'rm -rf
~/.eclipse' this issue persists.

Comment 4 Andrew Overholt 2005-11-01 19:41:02 UTC
I just tried to reproduce this bug with the proposed FC4 update (in
updates-testing) but I cannot.  If you can try out this update [1] and verify
that this issue is indeed fixed, I would appreciate it.

Thanks.

[1]
yum --enablerepo=updates-testing update eclipse-pde (or whatever)

Comment 5 Axon 2005-11-12 13:59:13 UTC
Seems to be working now for me on the latest version of Eclipse 3.1.1 downloaded
from the FC4 repo.

Comment 6 Axon 2005-11-12 14:09:29 UTC
Now I seem to be getting an NPE when I attempt to read information using extssh.
Not sure if it is related to this bug or a seperate issue (see attached
eclipse.log).

Comment 7 Axon 2005-11-12 14:10:53 UTC
Created attachment 120982 [details]
Eclipse log

Comment 8 Andrew Overholt 2005-11-12 16:54:56 UTC
(In reply to comment #6)
> Now I seem to be getting an NPE when I attempt to read information using extssh.
> Not sure if it is related to this bug or a seperate issue (see attached
> eclipse.log).

That's a separate issue:  bug 146782.

Can we close this?


Comment 9 John Thacker 2006-05-05 20:42:05 UTC
Closing due to lack of response.


Note You need to log in before you can comment on or make changes to this bug.