Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161511 - Import bookmark wizard is broken
Summary: Import bookmark wizard is broken
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: firefox
Version: 4
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Christopher Aillon
QA Contact:
URL:
Whiteboard:
: 165927 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 20:12 UTC by axgrau
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version: FC6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2007-01-23 20:56:07 UTC


Attachments (Terms of Use)

Description axgrau 2005-06-23 20:12:26 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.7.8) Gecko/20050524 Fedora/1.0.4-4 Firefox/1.0.4

Description of problem:
It's not possible to import bookmarks.

Version-Release number of selected component (if applicable):
firefox-1.0.4-4

How reproducible:
Always

Steps to Reproduce:
1.Bookmarks->Manage Bookmarks
2.File->Import
3.
  

Actual Results:  The import wizard is unusable. There are three buttons at the bottom with no text and nothing happens by clicking them. 

Additional info:

Comment 1 David Anderson 2005-07-14 08:27:55 UTC
Me too. The three buttons at the bottom have no text, and pressing them does 
nothing. 

Comment 2 John Mahowald 2005-07-22 17:37:46 UTC
Works for me with firefox-1.0.6-1.1.fc4. Update firefox and see if it presists.

Comment 3 David Anderson 2005-07-25 14:55:18 UTC
No, still not working with firefox-1.0.6-1.1.fc4. 

Comment 4 axgrau 2005-07-25 19:20:49 UTC
Same here. Still not working.

Comment 5 David Anderson 2005-07-25 19:31:12 UTC
I was using gtk-qt-engine at first, but that caused problems with openoffice. 
Now I'm using clearlooks GTK theme, so it doesn't seem to be caused by 
gtk-qt-engine, unless it's some side effect that still hangs around after 
disabling it. Are you using gtk-qt-engine, axgrau? 

Comment 6 axgrau 2005-07-26 06:55:45 UTC
No, I am not using gtk-qt-engine. Never installed. I normally use KDE, but I
have the same problem if I run Firefox in GNOME.

Comment 7 Peter Wainwright 2005-08-02 07:10:40 UTC
I've had the same problems, both with 1.0.4 and 1.0.6. However, it goes away if
I unset the "LANG" environment variable before running firefox. This seems like
the same bug Ubuntu users have reported, see:

http://mpt.net.nz/archive/2005/04/11/ubuntu#firefox
http://ubuntuforums.org/archive/index.php/t-22189.html



Comment 8 Peter Wainwright 2005-08-02 07:25:10 UTC
Sorry, I forgot some useful information:
As you may guess from my email, I'm using the locale setting
LANG=en_GB.UTF-8.
When using this setting, I get the following in the JavaScript console when I
pop up the "Import" dialog:
Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIStringBundle.GetStringFromName]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
chrome://global/content/bindings/wizard.xml :: _initWizardButton :: line 333" 
data: no]
Like the Ubuntu users, I get 3 buttons with icons but no labels, the middle
(back) button is greyed out, but none of them do anything when pressed.


Comment 9 David Anderson 2005-08-06 13:00:51 UTC
Same here as #7, #8 - unsetting LANG (from en_GB.UTF-8) both makes the 
dialogue work, and prevents the JavaScript console error. 

Comment 10 Peter Wainwright 2005-08-08 14:27:25 UTC
The problem seems to be some missing settings in the file 
locale/global/wizard.properties, which lives in the archive
/usr/lib/firefox-1.0.6/chrome/en-GB.jar.

Comparing this file with the en-US version shows:

[prw@desdemona tmp]$ diff -u en-{GB,US}/locale/global/wizard.properties
--- en-GB/locale/global/wizard.properties       2004-11-02 04:54:08.000000000 +0000
+++ en-US/locale/global/wizard.properties       2004-08-15 05:10:33.000000000 +0100
@@ -2,6 +2,10 @@
 button-next=Next >
 button-finish=Finish
 button-cancel=Cancel
+button-back-gnome=Back
+button-next-gnome=Next
+button-finish-gnome=Finish
+button-cancel-gnome=Cancel
 default-first-title=Welcome to the %S
 default-last-title=Completing the %S
 default-first-title-mac=Introduction

The "button-*-gnome" settings are required.

Comment 11 Kevin R. Page 2005-10-07 14:39:37 UTC
This problem afflicts the plugin finder dialog too.

Comment 12 Kevin R. Page 2005-10-07 14:41:01 UTC
*** Bug 165927 has been marked as a duplicate of this bug. ***

Comment 13 Christian Iseli 2007-01-22 10:13:43 UTC
This report targets the FC3 or FC4 products, which have now been EOL'd.

Could you please check that it still applies to a current Fedora release, and
either update the target product or close it ?

Thanks.

Comment 14 Kevin R. Page 2007-01-22 23:23:46 UTC
I'm no longer experiencing this problem: firefox-1.5.0.9-1.fc6
LANG=en_GB


Note You need to log in before you can comment on or make changes to this bug.