Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161497 - Java 1.5.0_03-b07 crashes under this kernel
Summary: Java 1.5.0_03-b07 crashes under this kernel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 3
Hardware: i686
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Dave Jones
QA Contact: Brian Brock
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 18:41 UTC by Nicolas Carranza
Modified: 2015-01-04 22:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-09-29 08:16:32 UTC


Attachments (Terms of Use)

Description Nicolas Carranza 2005-06-23 18:41:04 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.7) Gecko/20050415

Description of problem:
Running:
---
#!/bin/bash
while true
do
  java -version
done
---
causes java to crash randomly (~1/20 times). This does not happen under kernel-2.6.11-1.27_FC3

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.35_FC3.i686.rpm

How reproducible:
Always

Steps to Reproduce:
1. Run the script provided in the description.
2. Java causes a segmentation fault or cashes the creash an report a hs_err file
  

Actual Results:  The system remain stable.

Additional info:

Comment 1 Dave Jones 2005-07-08 00:29:16 UTC
please try echo 1 > /proc/sys/kernel/exec_shield


Comment 2 Dave Jones 2005-07-15 19:29:10 UTC
An update has been released for Fedora Core 3 (kernel-2.6.12-1.1372_FC3) which
may contain a fix for your problem.   Please update to this new kernel, and
report whether or not it fixes your problem.

If you have updated to Fedora Core 4 since this bug was opened, and the problem
still occurs with the latest updates for that release, please change the version
field of this bug to 'fc4'.

Thank you.


Note You need to log in before you can comment on or make changes to this bug.