Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 161492 - Starting snmpd gives segmentation fault if lm_sensors is running
Summary: Starting snmpd gives segmentation fault if lm_sensors is running
Keywords:
Status: CLOSED DUPLICATE of bug 150199
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: net-snmp
Version: 4.0
Hardware: athlon
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Radek Vokal
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2005-06-23 18:06 UTC by Peter Ison
Modified: 2007-11-30 22:07 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2005-06-24 08:11:59 UTC


Attachments (Terms of Use)

Description Peter Ison 2005-06-23 18:06:47 UTC
Description of problem:
This is a problem which appeared in RHEL4 after un upgrade from RHEL3.

"service snmpd restart" always reports failed on stopping the service and ok on 
starting. There are no other errors reported. After that "ps -A | egrep snmp" 
shows that snmpd is no longer running. 

With lm_sensors started "snmpd -f -Le" reports "segmentation fault". Stopping 
lm_sensors allows snmpd to run without the segmentation fault. I need them both 
running so that I can produce mrtg reports.

Running strace on the segmentation fault shows an access to /usr/lib/rpm/i386-
linux/macros. Perhaps this should be /usr/lib/rpm/athlon-linux/macros as is the 
case on another athlon pc running FC4 with lm_sensors and net-snmp-5.2.1-12 
with no problem.

Version-Release number of selected component (if applicable):
net-snmp-5.1.2-11

How reproducible:
Always

Steps to Reproduce:
1.lm_sensors and net-snmp are started at boot
2."service snmpd restart" repeatedly shows failed on stopping; ok on starting 
service
3."ps -A | egrep snmp" shows that snmpd is not running
  
Actual results:
snmpd fails to start

Expected results:
snmpd should be running

Additional info:
lm_sensors-2.8.7-2

/etc/sysconfig/lm_sensors
MODULE_0=i2c-sis630
MODULE_1=i2c-isa
MODULE_2=eeprom
MODULE_3=it87

sensor information is at /sys/devices/platform/i2c-1/1-0290

lm_sensors starts as S26 before snmpd at S50.

If I start snmpd and only then start lm_sensors, snmpd seems to keep running.  
That is an observation, not a solution to the problem.

Comment 1 Radek Vokal 2005-06-24 08:11:59 UTC
The bug is already fixed, will appear in next update

*** This bug has been marked as a duplicate of 150199 ***


Note You need to log in before you can comment on or make changes to this bug.